kernel: allow hwmon GSC driver for all targets
authorLuka Perkov <luka@openwrt.org>
Tue, 10 Sep 2013 22:26:30 +0000 (22:26 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 10 Sep 2013 22:26:30 +0000 (22:26 +0000)
- enable using hwmon GSC driver on all targets
- add a kmod package for it

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
SVN-Revision: 37933

package/kernel/linux/modules/hwmon.mk
target/linux/generic/patches-3.10/880-gateworks_system_controller.patch
target/linux/generic/patches-3.3/880-gateworks_system_controller.patch
target/linux/generic/patches-3.6/880-gateworks_system_controller.patch
target/linux/generic/patches-3.8/880-gateworks_system_controller.patch
target/linux/generic/patches-3.9/880-gateworks_system_controller.patch

index 5af311df66f0bc0e87ed0370d5513a5892ed4b7d..b1f4744330ba2458ce695f82ac4a748d06c664e9 100644 (file)
@@ -219,3 +219,18 @@ define KernelPacakge/hwmon-w83627hf/description
 endef
 
 $(eval $(call KernelPackage,hwmon-w83627hf))
+
+
+define KernelPackage/hwmon-gsc
+  TITLE:=Gateworks GSC monitoring support
+  KCONFIG:=CONFIG_SENSORS_GSC
+  FILES:=$(LINUX_DIR)/drivers/hwmon/gsc.ko
+  AUTOLOAD:=$(call AutoLoad,50,gsc)
+$(call AddDepends/hwmon)
+endef
+
+define KernelPacakge/hwmon-gsc/description
+  Kernel module for the Gateworks System Controller chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-gsc))
index 73dd583911c4f846e5a644b40802ea7a8e575a43..d923485020a2827d448d0e3c01be348dec85e240 100644 (file)
@@ -6,7 +6,7 @@
  
 +config SENSORS_GSC
 +      tristate "Gateworks System Controller"
-+      depends on I2C && (ARCH_DAVINCI || ARCH_CNS3XXX || ARCH_IXP4XX)
++      depends on I2C
 +      help
 +        If you say yes here you get support for the Gateworks System Controller.
 +
index 981610dad1a7daf12acd8672f826d3e3f8e7e192..d9a64810d9afb937d4d670413808aeadde5d652b 100644 (file)
@@ -6,7 +6,7 @@
  
 +config SENSORS_GSC
 +      tristate "Gateworks System Controller"
-+      depends on I2C && (ARCH_DAVINCI || ARCH_CNS3XXX || ARCH_IXP4XX)
++      depends on I2C
 +      help
 +        If you say yes here you get support for the Gateworks System Controller.
 +
index 02c9d8f9aa6f02934b103a9f7df5c83d542707b2..010dc295763ec9c5d2e4ad0423eb5cb44a498680 100644 (file)
@@ -6,7 +6,7 @@
  
 +config SENSORS_GSC
 +      tristate "Gateworks System Controller"
-+      depends on I2C && (ARCH_DAVINCI || ARCH_CNS3XXX || ARCH_IXP4XX)
++      depends
 +      help
 +        If you say yes here you get support for the Gateworks System Controller.
 +
index dd78ef8d072ca061ee8ba3d4b322f8f494c49064..1ec096062bdcaecaf243951b9b89f4ee6ab7ba5b 100644 (file)
@@ -6,7 +6,7 @@
  
 +config SENSORS_GSC
 +      tristate "Gateworks System Controller"
-+      depends on I2C && (ARCH_DAVINCI || ARCH_CNS3XXX || ARCH_IXP4XX)
++      depends on I2C
 +      help
 +        If you say yes here you get support for the Gateworks System Controller.
 +
index efb7c48abac3d1cd8073e33d7774caa86658a037..3bcca9c1927c00e1441a6961b217ca4a15b51c6b 100644 (file)
@@ -6,7 +6,7 @@
  
 +config SENSORS_GSC
 +      tristate "Gateworks System Controller"
-+      depends on I2C && (ARCH_DAVINCI || ARCH_CNS3XXX || ARCH_IXP4XX)
++      depends on I2C
 +      help
 +        If you say yes here you get support for the Gateworks System Controller.
 +