rules.mk: move DOWNLOAD_CHECK_CERTIFICATE to include/download.mk
authorChristian Marangi <ansuelsmth@gmail.com>
Mon, 3 Oct 2022 22:30:21 +0000 (00:30 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Wed, 5 Oct 2022 15:49:19 +0000 (17:49 +0200)
Move DOWNLOAD_CHECK_CERTIFICATE to include/download.mk as it's a better
place than exporting it in the global rules.mk makefile.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
include/download.mk
rules.mk

index 76bd374cf7e349f31196401725c170df9262cf88..9ff71540f756ff5e6980a86e944917d7e05e601b 100644 (file)
@@ -18,6 +18,9 @@ endif
 
 DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
 
+# Export options for download.pl
+export DOWNLOAD_CHECK_CERTIFICATE:=$(CONFIG_DOWNLOAD_CHECK_CERTIFICATE)
+
 define dl_method_git
 $(if $(filter https://github.com/% git://github.com/%,$(1)),github_archive,git)
 endef
index 2072658e782a5c0918d8b453820082b24c67747f..2de43d490d6c041f11f9c41d78c34a71833d3c30 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -257,9 +257,6 @@ ESED:=$(STAGING_DIR_HOST)/bin/sed -E -i -e
 MKHASH:=$(STAGING_DIR_HOST)/bin/mkhash
 # MKHASH is used in /scripts, so we export it here.
 export MKHASH
-# DOWNLOAD_CHECK_CERTIFICATE is used in /scripts, so we export it here.
-DOWNLOAD_CHECK_CERTIFICATE:=$(CONFIG_DOWNLOAD_CHECK_CERTIFICATE)
-export DOWNLOAD_CHECK_CERTIFICATE
 CP:=cp -fpR
 LN:=ln -sf
 XARGS:=xargs -r