build: add a prereq check for file (#15692)
authorFelix Fietkau <nbd@openwrt.org>
Thu, 24 Apr 2014 19:28:11 +0000 (19:28 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 24 Apr 2014 19:28:11 +0000 (19:28 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 40568

include/prereq-build.mk

index b7ada69bb418ba51c3cedbc05f277a5fffb637c5..2e8d712cb8596b98b69992e4848158b7d8fc833e 100644 (file)
@@ -187,3 +187,7 @@ endef
 $(eval $(call Require,getopt-extended, \
        Please install an extended getopt version that supports --long \
 ))
+
+$(eval $(call RequireCommand,file, \
+       Please install file. \
+))