ipqx0xx: add Generic subtarget
authorPaul Spooren <mail@aparcar.org>
Thu, 22 Aug 2019 00:59:24 +0000 (14:59 -1000)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 22 Aug 2019 19:15:28 +0000 (21:15 +0200)
Both targets miss a subtarget causing an image naming style which is
different from other all othe targets, even tho it already uses
`x/generic/` as subfolder as if the subtarget would exist.

This commit adds the Generic subtarget resulting in consistent naming.

    ~/src/openwrt/openwrt/bin/targets/ipq806x/generic$ ls
    openwrt-ipq806x-generic-netgear_d7800-initramfs-uImage
    openwrt-ipq806x-generic-netgear-d7800.manifest
    openwrt-ipq806x-generic-netgear_d7800-squashfs-factory.img
    openwrt-ipq806x-generic-netgear_d7800-squashfs-sysupgrade.bin

CC: John Crispin <john@phrozen.org>
Signed-off-by: Paul Spooren <mail@aparcar.org>
target/linux/ipq40xx/Makefile
target/linux/ipq40xx/generic/target.mk [new file with mode: 0644]
target/linux/ipq806x/Makefile
target/linux/ipq806x/generic/target.mk [new file with mode: 0644]

index 9b78d1f1bfc5c6145e584ee988cad6bf8296175b..9e26b277fa379b2e4beb21a121b5bb41f3c91603 100644 (file)
@@ -7,6 +7,7 @@ FEATURES:=squashfs fpu ramdisk nand
 CPU_TYPE:=cortex-a7
 CPU_SUBTYPE:=neon-vfpv4
 MAINTAINER:=John Crispin <john@phrozen.org>
+SUBTARGETS:=generic
 
 KERNEL_PATCHVER:=4.19
 
diff --git a/target/linux/ipq40xx/generic/target.mk b/target/linux/ipq40xx/generic/target.mk
new file mode 100644 (file)
index 0000000..f5cb1fb
--- /dev/null
@@ -0,0 +1 @@
+BOARDNAME:=Generic
index cd0e8b82ea31645a9dd1d3dcf4a61a807c0db543..19ed015ebce4702e57f9322b874f02124c86eff4 100644 (file)
@@ -9,6 +9,7 @@ FEATURES:=squashfs nand fpu ramdisk
 CPU_TYPE:=cortex-a15
 CPU_SUBTYPE:=neon-vfpv4
 MAINTAINER:=John Crispin <john@phrozen.org>
+SUBTARGETS:=generic
 
 KERNEL_PATCHVER:=4.14
 
diff --git a/target/linux/ipq806x/generic/target.mk b/target/linux/ipq806x/generic/target.mk
new file mode 100644 (file)
index 0000000..f5cb1fb
--- /dev/null
@@ -0,0 +1 @@
+BOARDNAME:=Generic