ar71xx: disable some tiny targets with kernel 4.14
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 5 Nov 2018 11:53:55 +0000 (12:53 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 5 Nov 2018 15:00:06 +0000 (16:00 +0100)
The bump to kernel 4.14 caused a massive increase in kernel size.

For most targets, switching them to dynamic partitioning allowed
to cope with this.

On some targets, the kernel partition is located behind the rootfs,
which disallows switching to dynamic partitioning as the boot location
would be altered, requiring a u-boot change.

Also within the tiny section, which disables kernel symbols etc
to decrease the image size,  the partition size is still too small.

Disable these targets for now, fixing image generation:

- Buffalo BHR-4GRV2
- Zbtlink ZBT-WE1526

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
target/linux/ar71xx/image/tiny.mk

index 86ed2c7f2b59debad9caf873ee74626a9dad97da..aabe68c2b90a2495e03d567262b1faeb6d0a5735 100644 (file)
@@ -9,7 +9,6 @@ define Device/bhr-4grv2
   IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to $$$$(ROOTFS_SIZE) | append-kernel | check-size $$$$(IMAGE_SIZE)
   IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | mkbuffaloimg
 endef
-TARGET_DEVICES += bhr-4grv2
 
 define Device/zbt-we1526
   DEVICE_TITLE := Zbtlink ZBT-WE1526
@@ -21,4 +20,3 @@ define Device/zbt-we1526
   MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware)
   IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to $$$$(ROOTFS_SIZE) | append-kernel | check-size $$$$(IMAGE_SIZE)
 endef
-TARGET_DEVICES += zbt-we1526
\ No newline at end of file