uhttpd: return after processing -d switch, only set ubus prefix if not already defined
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 11 Nov 2013 19:14:01 +0000 (19:14 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 11 Nov 2013 19:14:01 +0000 (19:14 +0000)
SVN-Revision: 38743

package/network/services/uhttpd/Makefile
package/network/services/uhttpd/files/ubus.default

index be1a1e27f133b13fd89d7003a079de98ea0f6ca9..46a39a1718cd8a6d6e153df5e7b4271316390c68 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_VERSION:=2013-09-13
+PKG_VERSION:=2013-11-11
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/uhttpd2.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=8eb20e0aad7412468975b2c9ce7e374ea3084e42
+PKG_SOURCE_VERSION:=881d6102cf1f7bc6b54ab395c5e4addbfe1ed34c
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
index ba6c289f842f6b7b48edd52e2ae7dc2c6d94b2be..397456db6a99a6cf0c3ddd9ae0c938d538a871dd 100644 (file)
@@ -1,2 +1,6 @@
-uci set uhttpd.main.ubus_prefix=/ubus
-uci commit uhttpd
+#!/bin/sh
+
+if [ -z "$(uci -q get uhttpd.main.ubus_prefix)" ]; then
+       uci set uhttpd.main.ubus_prefix=/ubus
+       uci commit uhttpd
+fi