Add audio feature flag.
authorLars-Peter Clausen <lars@metafoo.de>
Mon, 15 Feb 2010 20:03:18 +0000 (20:03 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Mon, 15 Feb 2010 20:03:18 +0000 (20:03 +0000)
There are targets which neither have usb host nor pci support but do have audio
capabilities. Those targets should expliclitly specifiy that they support audio
through the new feature flag. The audio feature flag is also implicitly selected
by the usb and pci feature flags.

SVN-Revision: 19643

package/kernel/modules/sound.mk
scripts/metadata.pl
target/Config.in
target/linux/uml/Makefile
target/linux/xburst/Makefile

index 9350dbf344351d426b3ee4da440890a9542c701a..53f65e5ad10aebd621d2c85c174603393e94e390 100644 (file)
@@ -10,7 +10,7 @@ SOUND_MENU:=Sound Support
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=Sound support
-  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT||TARGET_uml
+  DEPENDS:=@AUDIO_SUPPORT
   KCONFIG:= \
        CONFIG_SOUND \
        CONFIG_SND \
index 9260a1b24bdcf7709b74ed1a386b1a503daf7e85..c963964ba3ad8e7d781b3f17cb995a6fd518c5ff 100755 (executable)
@@ -152,6 +152,7 @@ sub target_config_features(@) {
 
        while ($_ = shift @_) {
                /broken/ and $ret .= "\tdepends BROKEN\n";
+               /audio/ and $ret .= "\tselect AUDIO_SUPPORT\n";
                /display/ and $ret .= "\tselect DISPLAY_SUPPORT\n";
                /gpio/ and $ret .= "\tselect GPIO_SUPPORT\n";
                /pci/ and $ret .= "\tselect PCI_SUPPORT\n";
index f5aa0430538e2d73893e503d68e1ca8a8a85f616..f881245c627e862c086243b7dca5fe59de81f16c 100644 (file)
@@ -11,6 +11,9 @@ config LINUX_2_6
 config HAS_FPU
        bool
 
+config AUDIO_SUPPORT
+       bool
+
 config DISPLAY_SUPPORT
        bool
 
@@ -18,6 +21,7 @@ config GPIO_SUPPORT
        bool
 
 config PCI_SUPPORT
+       select AUDIO_SUPPORT
        bool
 
 config PCIE_SUPPORT
@@ -27,6 +31,7 @@ config PCMCIA_SUPPORT
        bool
 
 config USB_SUPPORT
+       select AUDIO_SUPPORT
        bool
 
 config BIG_ENDIAN
index 5f3181fce21166a63b9e3621347e7490a90f60af..f2d9ce4525e9a227f657d5e36e56900c361a8fc7 100644 (file)
@@ -20,7 +20,7 @@ ARCH:=$(shell uname -m | sed \
 )
 BOARD:=uml
 BOARDNAME:=User Mode Linux
-FEATURES:=ext2
+FEATURES:=ext2 audio
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
 LINUX_VERSION:=2.6.30.10
index 7707c76045bd1013b5b51cc1b0d3a5e3d78a09e4..7fdb93ce17a2e3ca2f3499203a3a5f061cffe5b8 100644 (file)
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=xburst
 BOARDNAME:=XBurst JZ47x0
-FEATURES:=jffs2 tgz ubifs
+FEATURES:=jffs2 tgz ubifs audio
 
-LINUX_VERSION:=2.6.32.8
+LINUX_VERSION:=2.6.32.7
 
 DEVICE_TYPE=other