build: only print skipped packages that were selected
authorFelix Fietkau <nbd@openwrt.org>
Wed, 22 Oct 2014 08:57:50 +0000 (08:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 22 Oct 2014 08:57:50 +0000 (08:57 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 43023

include/package-ipkg.mk

index b8c8cd6f99cc9938fae2fdc72b37b6d3f0fd3d3d..13bb7c7d42223edfd1ed465403b9f4b447c03804 100644 (file)
@@ -109,7 +109,7 @@ ifeq ($(DUMP),)
                        echo "$(1)" >> $(PKG_INSTALL_STAMP)
         endif
       else
-        $$(info WARNING: skipping $(1) -- package not selected)
+        $(if $(CONFIG_PACKAGE_$(1)),$$(info WARNING: skipping $(1) -- package not selected))
       endif
     endif
     endif