brcm63xx: delete uncompressed kernels after use
authorJonas Gorski <jogo@openwrt.org>
Mon, 1 Jun 2015 12:37:34 +0000 (12:37 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 1 Jun 2015 12:37:34 +0000 (12:37 +0000)
Delete the dtb appended, uncompressed kernels after having compressed
them, so they don't end in the image builder.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 45869

target/linux/brcm63xx/image/Makefile

index 139a2e307658685a8f5ead45e5fbb6202d79a31c..cb9bf271dd0db6395cd4301cf5d68b1d8a12547a 100755 (executable)
@@ -167,6 +167,7 @@ define Image/PrepareLoaderDTB
        # append dtb to vmlinux, then build a standard LZMA loader
        cat $(KDIR)/vmlinux$(1) $(DTS_DIR)/$(2).dtb > $(KDIR)/vmlinux$(1)-$(2)
        $(call Image/PrepareLoader,$(1)-$(2),$(3),$(4))
+       rm -f $(KDIR)/vmlinux$(1)-$(2)
 endef
 
 define Image/PrepareCFELzmaKernel
@@ -198,6 +199,7 @@ define Image/PrepareCFELzmaKernelDTB
        $(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $(DTS_DIR)/$(1).dtb ../dts/$(1).dts
        cat $(KDIR)/vmlinux $(DTS_DIR)/$(1).dtb > $(KDIR)/vmlinux-$(1)
        $(call Image/PrepareCFELzmaKernel,-$(1))
+       rm -f $(KDIR)/vmlinux-$(1)
 endef
 
 define Image/Prepare