ramips, mt7620: reproducible elecom-header uid/gid
authorPaul Spooren <mail@aparcar.org>
Wed, 6 Nov 2019 21:15:21 +0000 (11:15 -1000)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 6 Nov 2019 22:23:52 +0000 (23:23 +0100)
The elecom-header renames the firmware image to v_0.0.0.bin, stores its
MD5 sum as v_0.0.0.md5 and tars both files again.

Both v_0.0.0 files are created as the build user making it harder to
reproduce.

This commit sets the owner/group of both files to root by adding extra
options to the final tar command.

Before:
0 buildbot   (101) buildbot   (102)  3932164 2019-11-05 14:43:22.000000 v_0.0.0.bin
0 buildbot   (101) buildbot   (102)       33 2019-11-05 14:43:22.000000 v_0.0.0.md5

After:
0 root         (0) root         (0)  3932164 2019-11-05 23:43:08.000000 v_0.0.0.bin
0 root         (0) root         (0)       33 2019-11-05 23:43:08.000000 v_0.0.0.md5

Signed-off-by: Paul Spooren <mail@aparcar.org>
target/linux/ramips/image/mt7620.mk

index bca2363699e5d773c441a53e780e61c4530801f0..88437a69040de2609592b04091b32c3228c3005e 100644 (file)
@@ -13,7 +13,7 @@ define Build/elecom-header
        ) | mkhash md5 > $(KDIR)/v_0.0.0.md5
        $(STAGING_DIR_HOST)/bin/tar -c \
                $(if $(SOURCE_DATE_EPOCH),--mtime=@$(SOURCE_DATE_EPOCH)) \
-               -f $@ -C $(KDIR) v_0.0.0.bin v_0.0.0.md5
+               --owner=0 --group=0 -f $@ -C $(KDIR) v_0.0.0.bin v_0.0.0.md5
 endef
 
 define Device/aigale_ai-br100