uhttpd: always turn on TLS support, include ustream-ssl as a build dependency
authorFelix Fietkau <nbd@openwrt.org>
Tue, 22 Jan 2013 15:05:04 +0000 (15:05 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 22 Jan 2013 15:05:04 +0000 (15:05 +0000)
SVN-Revision: 35295

package/network/services/uhttpd/Makefile

index 6f3d1507aea43276518980c2ad1a7c141b337b1e..f03ecc43981963a5829866c29dce537a08167299 100644 (file)
@@ -18,11 +18,11 @@ PKG_SOURCE_VERSION:=14e3971c37e6feb0ec5eda0988e07d8a786ba9f9
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
-PKG_CONFIG_DEPENDS = CONFIG_PACKAGE_uhttpd-mod-tls
+PKG_BUILD_DEPENDS = ustream-ssl
+
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
-
 define Package/uhttpd/default
   SECTION:=net
   CATEGORY:=Network
@@ -102,7 +102,7 @@ endef
 
 TARGET_LDFLAGS += -lcrypt
 
-CMAKE_OPTIONS = -DTLS_SUPPORT=$(if $(CONFIG_PACKAGE_uhttpd-mod-tls),on,off)
+CMAKE_OPTIONS = -DTLS_SUPPORT=on
 
 define Package/uhttpd/install
        $(INSTALL_DIR) $(1)/etc/init.d