kernel: Add snd-intel-nhlt.ko to kmod-sound-hda-intel
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 23 Feb 2020 15:41:16 +0000 (16:41 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 28 Feb 2020 16:50:46 +0000 (17:50 +0100)
With kernel 5.4 kmod-sound-hda-intel also needs snd-intel-nhlt.ko, but
this kernel module is only build on x86, make the OpenWrt kmod depend on
TARGET_x86.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/sound.mk

index a49ba6da6a817584257d9a859839ea3c60334b9c..f975103e508cb96c110cbc6b24c410bc125cdb05 100644 (file)
@@ -502,11 +502,13 @@ $(eval $(call KernelPackage,sound-hda-codec-hdmi))
 define KernelPackage/sound-hda-intel
   SUBMENU:=$(SOUND_MENU)
   TITLE:=HD Audio Intel Driver
+  DEPENDS:=@TARGET_x86
   KCONFIG:= \
        CONFIG_SOUND_PCI \
        CONFIG_SND_HDA_INTEL
   FILES:= \
-       $(LINUX_DIR)/sound/pci/hda/snd-hda-intel.ko
+       $(LINUX_DIR)/sound/pci/hda/snd-hda-intel.ko \
+       $(LINUX_DIR)/sound/hda/snd-intel-nhlt.ko@ge5.4
   AUTOLOAD:=$(call AutoProbe,snd-hda-intel)
   $(call AddDepends/sound,kmod-sound-hda-core)
 endef