rules_mk: don't include wrapped bin with external toolchains
authorChristian Marangi <ansuelsmth@gmail.com>
Sun, 3 Jul 2022 00:06:21 +0000 (02:06 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Sun, 24 Jul 2022 17:53:43 +0000 (19:53 +0200)
Don't add wrapped bin to the TARGET_PATH as it does cause compilation
error.

cmake.mk will use the "command -v" and will use the wrapped bin instead
of the external toolchain bin as they have the same name and command
will select the first result.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
rules.mk

index dd375ff3d510d28c1ada20e60fa3e35f13861763..5a56fd6f4ace889cc5f903d70e5c0cc9342666e4 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -208,7 +208,6 @@ ifndef DUMP
       ifneq ($(TOOLCHAIN_LIB_DIRS),)
         TARGET_LDFLAGS+= $(patsubst %,-L%,$(TOOLCHAIN_LIB_DIRS))
       endif
-      TARGET_PATH:=$(TOOLCHAIN_DIR)/bin:$(TARGET_PATH)
     endif
   endif
 endif