linux: fix framebuffer kmods for >= 3.15
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 31 Jan 2015 13:15:45 +0000 (13:15 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 31 Jan 2015 13:15:45 +0000 (13:15 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44227

package/kernel/linux/modules/video.mk

index 77ba29a00017f97b727b5b1e83d432e822a8f2db..2bf80546e5f22cd7334707a19caf3ca7a29e06b8 100644 (file)
@@ -16,7 +16,9 @@ define KernelPackage/fb
   TITLE:=Framebuffer support
   DEPENDS:=@DISPLAY_SUPPORT
   KCONFIG:=CONFIG_FB
-  FILES:=$(LINUX_DIR)/drivers/video/fb.ko
+  FILES:= \
+       $(LINUX_DIR)/drivers/video/fb.ko@lt3.15 \
+       $(LINUX_DIR)/drivers/video/fbdev/core/fb.ko@ge3.15
   AUTOLOAD:=$(call AutoLoad,06,fb)
 endef
 
@@ -36,7 +38,9 @@ define KernelPackage/fb-cfb-fillrect
   TITLE:=Framebuffer software rectangle filling support
   DEPENDS:=+kmod-fb
   KCONFIG:=CONFIG_FB_CFB_FILLRECT
-  FILES:=$(LINUX_DIR)/drivers/video/cfbfillrect.ko
+  FILES:= \
+       $(LINUX_DIR)/drivers/video/cfbfillrect.ko@lt3.15 \
+       $(LINUX_DIR)/drivers/video/fbdev/core/cfbfillrect.ko@ge3.15
   AUTOLOAD:=$(call AutoLoad,07,cfbfillrect)
 endef
 
@@ -52,7 +56,9 @@ define KernelPackage/fb-cfb-copyarea
   TITLE:=Framebuffer software copy area support
   DEPENDS:=+kmod-fb
   KCONFIG:=CONFIG_FB_CFB_COPYAREA
-  FILES:=$(LINUX_DIR)/drivers/video/cfbcopyarea.ko
+  FILES:= \
+       $(LINUX_DIR)/drivers/video/cfbcopyarea.ko@lt3.15 \
+       $(LINUX_DIR)/drivers/video/fbdev/core/cfbcopyarea.ko@ge3.15
   AUTOLOAD:=$(call AutoLoad,07,cfbcopyarea)
 endef
 
@@ -67,7 +73,9 @@ define KernelPackage/fb-cfb-imgblt
   TITLE:=Framebuffer software image blit support
   DEPENDS:=+kmod-fb
   KCONFIG:=CONFIG_FB_CFB_IMAGEBLIT
-  FILES:=$(LINUX_DIR)/drivers/video/cfbimgblt.ko
+  FILES:= \
+       $(LINUX_DIR)/drivers/video/cfbimgblt.ko@lt3.15 \
+       $(LINUX_DIR)/drivers/video/fbdev/core/cfbimgblt.ko@ge3.15
   AUTOLOAD:=$(call AutoLoad,07,cfbimgblt)
 endef