geos: support cpu MSR register and flashrom for coreboot upgrades
authorFlorian Fainelli <florian@openwrt.org>
Mon, 28 Mar 2011 21:31:02 +0000 (21:31 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 28 Mar 2011 21:31:02 +0000 (21:31 +0000)
The early versions of the platform shipped with coreboot 3.0, which had some issues rebooting correctly the first time.

Allow the user to upgrade his BIOS from Linux.

Signed-of-by: Philip Prindeville <philipp@redfish-solutions.com>
SVN-Revision: 26344

target/linux/x86/geos/target.mk

index faf616690b3b2d33f231935c4c343e1a5c407699..324525fbf9e7900a26e50021abc650b96b9a6406 100644 (file)
@@ -16,8 +16,10 @@ DEFAULT_PACKAGES += kmod-ata-via-sata \
             kmod-cfg80211 kmod-mac80211 \
             kmod-mppe kmod-pppoe kmod-pppoa kmod-pppol2tp \
             kmod-ath kmod-ath5k kmod-ath9k \
+            kmod-cpu-msr \
             soloscli linux-atm br2684ctl bridge ppp ppp-mod-pppoa \
-            libopenssl ocf-crypto-headers zlib hwclock hostapd
+            libopenssl ocf-crypto-headers zlib hwclock hostapd \
+            flashrom
 
 CS5535_MASK:=0x0E000048