move isp116x driver to target specific modules.mk
authorFlorian Fainelli <florian@openwrt.org>
Wed, 25 Jul 2012 15:50:45 +0000 (15:50 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 25 Jul 2012 15:50:45 +0000 (15:50 +0000)
SVN-Revision: 32865

package/kernel/modules/usb.mk
target/linux/ppc40x/modules.mk

index 02731dbd06784a885ed5d489bf0dc0de07074c9b..a54f2aa3f4e198a7d6984e0b0dc3376c813bc8c2 100644 (file)
@@ -110,25 +110,6 @@ endef
 $(eval $(call KernelPackage,usb-ohci,1))
 
 
-define KernelPackage/usb-isp116x-hcd
-  TITLE:=Support for the ISP116x USB Host Controller
-  DEPENDS:=@TARGET_ppc40x
-  KCONFIG:= \
-       CONFIG_USB_ISP116X_HCD \
-       CONFIG_USB_ISP116X_HCD_OF=y \
-       CONFIG_USB_ISP116X_HCD_PLATFORM=n
-  FILES:=$(LINUX_DIR)/drivers/usb/host/isp116x-hcd.ko
-  AUTOLOAD:=$(call AutoLoad,50,isp116x-hcd)
-  $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-isp116x-hcd/description
-  Kernel support for the ISP116X USB Host Controller
-endef
-
-$(eval $(call KernelPackage,usb-isp116x-hcd))
-
-
 define KernelPackage/usb2
   TITLE:=Support for USB2 controllers
   DEPENDS:=+TARGET_brcm47xx:kmod-usb-brcm47xx
index 8859a2757839d726bf4ff2027e85d779e3534ab2..4db39fac768e6f3a1ccb6d54392f95ef7adc8c51 100644 (file)
@@ -20,3 +20,22 @@ define KernelPackage/ata-magicbox-cf/description
 endef
 
 $(eval $(call KernelPackage,ata-magicbox-cf))
+
+
+define KernelPackage/usb-isp116x-hcd
+  TITLE:=Support for the ISP116x USB Host Controller
+  DEPENDS:=@TARGET_ppc40x
+  KCONFIG:= \
+       CONFIG_USB_ISP116X_HCD \
+       CONFIG_USB_ISP116X_HCD_OF=y \
+       CONFIG_USB_ISP116X_HCD_PLATFORM=n
+  FILES:=$(LINUX_DIR)/drivers/usb/host/isp116x-hcd.ko
+  AUTOLOAD:=$(call AutoLoad,50,isp116x-hcd)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-isp116x-hcd/description
+  Kernel support for the ISP116X USB Host Controller
+endef
+
+$(eval $(call KernelPackage,usb-isp116x-hcd))