portability fix
authorFelix Fietkau <nbd@openwrt.org>
Sat, 14 Oct 2006 14:26:40 +0000 (14:26 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 14 Oct 2006 14:26:40 +0000 (14:26 +0000)
SVN-Revision: 5082

package/alsa/Makefile
package/alsa/patches/110-cp_command.patch [new file with mode: 0644]

index 47ad4456bfd1a8040c66946807947a9195937acd..2ac0b9433b97c4612701f3294f78105b9bb990c2 100644 (file)
@@ -67,6 +67,7 @@ define Build/Compile
                ARCH="$(LINUX_KARCH)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                c_opts="$(KERNEL_C_OPTS)" \
+               CP="$(CP)" \
                all
 endef
 
diff --git a/package/alsa/patches/110-cp_command.patch b/package/alsa/patches/110-cp_command.patch
new file mode 100644 (file)
index 0000000..68499e8
--- /dev/null
@@ -0,0 +1,20 @@
+diff -ur alsa.old/Makefile alsa.dev/Makefile
+--- alsa.old/Makefile  2006-10-14 07:07:48.000000000 -0700
++++ alsa.dev/Makefile  2006-10-14 07:08:45.000000000 -0700
+@@ -100,6 +100,7 @@
+ SUBDIRS  += parisc
+ endif
+ CSUBDIRS += include test utils
++CP = cp -fPR
+ KCONFIG_FILES = $(shell find $(SND_TOPDIR) -name Kconfig) $(shell find $(SND_TOPDIR)/alsa-kernel/ -name Kconfig)
+@@ -115,7 +116,7 @@
+       if [ ! -d include/sound -a ! -L include/sound ]; then \
+         ln -sf ../alsa-kernel/include include/sound ; \
+       fi
+-      cp -auvf include/version.h include/sound/version.h
++      $(CP) include/version.h include/sound/version.h
+ utils/mod-deps: utils/mod-deps.c
+       gcc utils/mod-deps.c -o utils/mod-deps