ipv6-support: don't use disable_ipv6
authorSteven Barth <cyrus@openwrt.org>
Sun, 13 Jan 2013 17:25:43 +0000 (17:25 +0000)
committerSteven Barth <cyrus@openwrt.org>
Sun, 13 Jan 2013 17:25:43 +0000 (17:25 +0000)
SVN-Revision: 35134

package/network/ipv6/ipv6-support/Makefile
package/network/ipv6/ipv6-support/files/dhcpv6.sh

index 0d596d4d3b01ac55342d2260bf38cd11d00a36dc..74286e79b878100155a20a83d04e81ae6f72a5f4 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipv6-support
-PKG_VERSION:=2013-01-02
+PKG_VERSION:=2013-01-13
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 9609f04d5c65cfaaa234fa124d9440582938d38b..5a668cd9b1ab6f905e7b9343cbc28ec23d31224a 100755 (executable)
@@ -20,9 +20,8 @@ if [ "$state" == "started" ]; then
        conf_set "$device" accept_ra 2
        conf_set "$device" forwarding 2
 
-       # Trigger RS
-       conf_set "$device" disable_ipv6 1
-       conf_set "$device" disable_ipv6 0
+       # Send RS on interface
+       [ -x /usr/sbin/6relayd ] && /usr/sbin/6relayd -s "$device"
 
        exit 0
 elif [ "$state" == "stopped" ]; then