ath79: gl-ar750s: reduce kernel size to 2M in image Makefile
authorChuanhong Guo <gch981213@gmail.com>
Wed, 8 Jan 2020 12:18:56 +0000 (20:18 +0800)
committerChuanhong Guo <gch981213@gmail.com>
Sat, 11 Jan 2020 02:37:04 +0000 (10:37 +0800)
u-boot splits nand factory firmware at 2M offset, flash the first
part as kernel into spi nor and the other part as ubi into nand
flash. With previous commit increasing kernel size to 4M, generated
factory firmware is broken because ubi is at 4M offset.

This commit reduces kernel size definition to 2M in image Makefile,
producing proper factory image. Partition size in dts is kept
unchanged so that sysupgrade to a firmware with 2M+ kernel still
works.

Fixes: b496a2294c ("ath79: GL-AR750S: provide NAND support; increase kernel to 4 MB")
Reported-by: Jeff Kletsky <git-commits@allycomm.com>
Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
target/linux/ath79/image/nand.mk

index c6a1441ed9797f2f2d4d356975cf92a49af6509f..cc775d52b64f5a42376feb8ac67d98c629c3880b 100644 (file)
@@ -82,7 +82,7 @@ define Device/glinet_gl-ar750s-common
   DEVICE_MODEL := GL-AR750S
   DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9887-ct kmod-usb2 \
        kmod-usb-storage block-mount
-  KERNEL_SIZE := 4096k
+  KERNEL_SIZE := 2048k
   IMAGE_SIZE := 16000k
   PAGESIZE := 2048
   VID_HDR_OFFSET := 2048