nftables: remove dependency on kmod-nf-nat
authorMatthias Schiffer <mschiffer@universe-factory.net>
Thu, 25 Jan 2018 17:11:37 +0000 (18:11 +0100)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Wed, 31 Jan 2018 12:32:40 +0000 (13:32 +0100)
For minimal firewall setups, NAT support may be unnecessary.

It would be possible to further reduce the minimum number of installed
modules, e.g. by separating IPv4 and IPv6 support or moving conntrack
support into a separate kmod package. We go with a more complete
kmod-nft-core for now, until a concrete usecase for smaller packages
arises.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
package/network/utils/nftables/Makefile

index e78c6f20acaa716a7a7dc96f237179eb3d2475ba..d1c9e206c44dbefc883ea96780493b45e61565fd 100644 (file)
@@ -31,7 +31,7 @@ define Package/nftables
   CATEGORY:=Network
   SUBMENU:=Firewall
   TITLE:=nftables packet filtering userspace utility
-  DEPENDS:=+kmod-nft-core +kmod-nft-nat +libnftnl
+  DEPENDS:=+kmod-nft-core +libnftnl
   URL:=http://netfilter.org/projects/nftables/
 endef