tools: drop gptfdisk and popt
authorZoltan HERPAI <wigyori@uid0.hu>
Sat, 23 Apr 2022 17:15:57 +0000 (19:15 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Sat, 23 Apr 2022 17:16:55 +0000 (19:16 +0200)
These host tools were built for the SiFive-boards, but the GPT support
has appeared in firmware-utils/ptgen as well, and the SD-card image
generation has been ported over.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
tools/Makefile
tools/gptfdisk/Makefile [deleted file]
tools/popt/Makefile [deleted file]

index 5927acf23d3903e870ee0e05c5b2debd86634e46..ec382b41225244a6c0edef9c5dfce02252e4b6d9 100644 (file)
@@ -31,7 +31,6 @@ tools-$(BUILD_ISL) += isl
 tools-$(BUILD_TOOLCHAIN) += expat gmp mpc mpfr
 tools-$(CONFIG_TARGET_apm821xx)$(CONFIG_TARGET_gemini) += genext2fs
 tools-$(CONFIG_TARGET_ath79) += lzma-old squashfs
-tools-$(CONFIG_TARGET_hifiveu) += gptfdisk popt
 tools-$(CONFIG_TARGET_mxs) += elftosb sdimage
 tools-$(CONFIG_TARGET_tegra) += cbootimage cbootimage-configs
 tools-$(CONFIG_USES_MINOR) += kernel2minor
diff --git a/tools/gptfdisk/Makefile b/tools/gptfdisk/Makefile
deleted file mode 100644 (file)
index e2adc74..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-# SPDX-License-Identifier: GPL-2.0-only
-#
-# Copyright (C) 2021 OpenWrt.org
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=gptfdisk
-PKG_VERSION:=1.0.8
-
-PKG_SOURCE:=gptfdisk-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/gptfdisk
-PKG_HASH:=95d19856f004dabc4b8c342b2612e8d0a9eebdd52004297188369f152e9dc6df
-
-PKG_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR) sgdisk
-endef
-
-define Host/Install
-       $(INSTALL_BIN) $(HOST_BUILD_DIR)/sgdisk $(STAGING_DIR_HOST)/bin/
-endef
-
-define Host/Clean
-       rm -f $(STAGING_DIR_HOST)/bin/sgdisk
-endef
-
-$(eval $(call HostBuild))
diff --git a/tools/popt/Makefile b/tools/popt/Makefile
deleted file mode 100644 (file)
index e113f81..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-# SPDX-License-Identifier: GPL-2.0-or-later
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=popt
-PKG_VERSION:=1.16
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:= \
-       http://distfiles.gentoo.org/distfiles/ \
-       http://distcache.freebsd.org/ports-distfiles/ \
-       http://rpm5.org/files/popt/
-PKG_HASH:=e728ed296fe9f069a0e005003c3d6b2dde3d9cad453422a10d6558616d304cc8
-
-PKG_FIXUP:=autoreconf
-PKG_REMOVE_FILES:=autogen.sh aclocal.m4
-
-PKG_INSTALL:=1
-PKG_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/host-build.mk
-
-HOST_CONFIGURE_ARGS += --enable-shared --enable-static
-
-HOST_CFLAGS += $(FPIC)
-
-define Host/Clean
-       rm -f $(STAGING_DIR_HOST)/lib/libpopt*
-       rm -f $(STAGING_DIR_HOST)/usr/include/popt.h
-endef
-
-$(eval $(call HostBuild))