Profiles: Move wpad-mini to the profiles that use it, rather than default for all...
authorDaniel Dickinson <crazycshore@gmail.com>
Wed, 8 Dec 2010 00:40:24 +0000 (00:40 +0000)
committerDaniel Dickinson <crazycshore@gmail.com>
Wed, 8 Dec 2010 00:40:24 +0000 (00:40 +0000)
SVN-Revision: 24314

target/linux/brcm63xx/Makefile
target/linux/brcm63xx/profiles/100-Broadcom.mk
target/linux/brcm63xx/profiles/101-Broadcom-wl.mk
target/linux/brcm63xx/profiles/102-Atheros.mk
target/linux/brcm63xx/profiles/103-Ralink.mk

index 5bdc10384d1e9f48622196e3f0265dd5e4941b2c..9b9043269f12f2b64a8dc2182fd0edb7cde602db 100644 (file)
@@ -14,7 +14,7 @@ LINUX_VERSION:=2.6.35.9
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini kmod-switch gpioctl
+DEFAULT_PACKAGES += kmod-switch gpioctl
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
index b7e1f46ec57b9ab784f51fe8ab20686d20a72c7e..bc68f14937e4d9c33353240a5496b456643fed32 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Broadcom
   NAME:=Broadcom WiFi (default)
-  PACKAGES:=kmod-b43
+  PACKAGES:=kmod-b43 wpad-mini
 endef
 
 define Profile/Broadcom/Description
index d67298cc9dcdd63f712a6e59df112e6a523803ce..4f2d605eb70e809c64416127e3c8c823eb0aec1f 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Broadcom-wl
   NAME:=Broadcom BCM43xx WiFi (wl, proprietary)
-  PACKAGES:=-wpad-mini kmod-brcm-wl wlc nas
+  PACKAGES:= kmod-brcm-wl wlc nas
 endef
 
 define Profile/Broadcom-wl/Description
index 029586848f1344e592f35d8d3484c232f2f92806..c6d2da636ea58de886480aeb3a507a4b2d42ec9a 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Atheros
   NAME:=Atheros WiFi (default)
-  PACKAGES:=kmod-madwifi
+  PACKAGES:=kmod-madwifi wpad-mini
 endef
 
 define Profile/Atheros/Description
index 0d78ae4a5a6a5376181aaf1dab0479dcb88be657..412c5a45adf2aba0bf3e4bade74d690375b60a01 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Ralink
   NAME:=Ralink WiFi
-  PACKAGES:=kmod-rt61-pci
+  PACKAGES:=kmod-rt61-pci wpad-mini
 endef
 $(eval $(call Profile,Ralink))