ramips: fix build of TRENDnet TEW-69xGR images
authorMathias Kresin <dev@kresin.me>
Fri, 19 Aug 2016 23:18:51 +0000 (01:18 +0200)
committerMathias Kresin <dev@kresin.me>
Sat, 20 Aug 2016 09:47:25 +0000 (11:47 +0200)
The image generation for TEW-691GR and TEW-692GR was broken since
79d02229 due to the move of the UMedia recipe to another Makefile.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/image/rt3883.mk

index 74c12404dfa20b1e9ee987bc31c7dc90de9760c5..edfd43cd6b216c3ae669f5ac54837e9dddba2f6c 100644 (file)
@@ -2,6 +2,26 @@
 # RT3662/RT3883 Profiles
 #
 
+define Device/TEW691GR
+  DTS := TEW-691GR
+  IMAGES += factory.bin
+  IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | umedia-header 0x026910
+  DEVICE_TITLE := TRENDnet TEW-691GR
+  DEVICE_PACKAGES := swconfig
+endef
+TARGET_DEVICES += TEW691GR
+
+
+define Device/TEW692GR
+  DTS := TEW-692GR
+  IMAGES += factory.bin
+  IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | umedia-header 0x026920
+  DEVICE_TITLE := TRENDnet TEW-692GR
+  DEVICE_PACKAGES := swconfig
+endef
+TARGET_DEVICES += TEW692GR
+
+
 # $(1) = squashfs/initramfs
 # $(2) = lowercase board name
 # $(3) = dts file
@@ -41,8 +61,6 @@ Image/Build/Profile/DIR645=$(call BuildFirmware/Seama/$(1),$(1),dir-645,DIR-645,
 hpm_mtd_size=16449536
 Image/Build/Profile/HPM=$(call BuildFirmware/CustomFlash/$(1),$(1),hpm,HPM,$(hpm_mtd_size))
 Image/Build/Profile/RTN56U=$(call BuildFirmware/RTN56U/$(1),$(1),rt-n56u,RT-N56U)
-Image/Build/Profile/TEW691GR=$(call BuildFirmware/UMedia/$(1),$(1),tew-691gr,TEW-691GR,0x026910)
-Image/Build/Profile/TEW692GR=$(call BuildFirmware/UMedia/$(1),$(1),tew-692gr,TEW-692GR,0x026920)
 kernel_size_BR6475ND:=2097152
 rootfs_size_BR6475ND:=5832704
 Image/Build/Profile/BR6475ND=$(call BuildFirmware/EdimaxCombined/$(1),$(1),br-6475nd,BR-6475ND,$(kernel_size_BR6475ND),$(rootfs_size_BR6475ND),CSYS,RN54,0x70000,0x01100000)
@@ -76,20 +94,6 @@ endef
 LEGACY_DEVICES += RTN56U
 
 
-define LegacyDevice/TEW691GR
-  DEVICE_TITLE := TRENDnet TEW-691GR
-  DEVICE_PACKAGES := swconfig
-endef
-LEGACY_DEVICES += TEW691GR
-
-
-define LegacyDevice/TEW692GR
-  DEVICE_TITLE := TEW692GR
-  DEVICE_PACKAGES := swconfig
-endef
-LEGACY_DEVICES += TEW692GR
-
-
 define LegacyDevice/BR6475ND
   DEVICE_TITLE := Edimax BR-6475nD
   DEVICE_PACKAGES := swconfig