kernel/modules: add kmod-ip6-vti
authorJohn Crispin <john@openwrt.org>
Fri, 12 Feb 2016 08:30:09 +0000 (08:30 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 12 Feb 2016 08:30:09 +0000 (08:30 +0000)
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
SVN-Revision: 48703

package/kernel/linux/modules/netsupport.mk

index cbf2ffbd358f2e577c59e92b47ab175afbfccc25..77bd67a7c3b8424c8df2444192b302e3a3597e1c 100644 (file)
@@ -420,6 +420,22 @@ endef
 $(eval $(call KernelPackage,ip-vti))
 
 
+define KernelPackage/ip6-vti
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=IPv6 VTI (Virtual Tunnel Interface)
+  DEPENDS:=+kmod-iptunnel +kmod-ip6-tunnel +kmod-ipsec6
+  KCONFIG:=CONFIG_IPV6_VTI
+  FILES:=$(LINUX_DIR)/net/ipv6/ip6_vti.ko
+  AUTOLOAD:=$(call AutoLoad,33,ip6_vti)
+endef
+
+define KernelPackage/ip6-vti/description
+ Kernel modules for IPv6 VTI (Virtual Tunnel Interface)
+endef
+
+$(eval $(call KernelPackage,ip6-vti))
+
+
 define KernelPackage/iptunnel4
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IPv4 tunneling