add support for DS2482 1-Wire I2C bus master
authorFlorian Fainelli <florian@openwrt.org>
Tue, 16 Aug 2011 20:33:55 +0000 (20:33 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 16 Aug 2011 20:33:55 +0000 (20:33 +0000)
Signed-off-by: Wojciech Dubowik <Wojciech.Dubowik@neratec.com>
SVN-Revision: 28010

package/kernel/modules/w1.mk

index c4ab6165cc69c667d5a6f07e5cfa2ddb742e5208..c2bdd7099a2ded45a54aa73e17018a6e1a829e6d 100644 (file)
@@ -48,6 +48,23 @@ endef
 
 $(eval $(call KernelPackage,w1-master-gpio))
 
+define KernelPackage/w1-master-ds2482
+  TITLE:=DS2482 1-wire i2c bus master driver
+  KCONFIG:=CONFIG_W1_MASTER_DS2482
+  FILES:=$(W1_MASTERS_DIR)/ds2482.ko
+  AUTOLOAD:=$(call AutoLoad,60,ds2482)
+  $(call AddDepends/w1,+kmod-i2c-core)
+endef
+
+define KernelPackage/w1-master-ds2482/description
+  Kernel module for the DS2482 i2c 1-wire bus master driver
+  NOTE: Init with: echo ds2482 0x18 > /sys/bus/i2c/devices/i2c-0/new_device
+  or use owfs
+endef
+
+$(eval $(call KernelPackage,w1-master-ds2482))
+
+
 define KernelPackage/w1-master-ds2490
   TITLE:=DS2490 1-wire usb bus master driver
   DEPENDS:=@USB_SUPPORT +kmod-usb-core