sunxi: add support for Retro Games Limited C=64 Mini (RGL001)
authorZoltan HERPAI <wigyori@uid0.hu>
Fri, 24 Apr 2020 13:44:01 +0000 (15:44 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Thu, 21 Apr 2022 07:18:36 +0000 (09:18 +0200)
CPU: Allwinner A20 dual-core Cortex A7
Memory: 256/512Mb
Storage: 128Mb NAND
USB: 2x USB2.0

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/boot/uboot-sunxi/Makefile
package/boot/uboot-sunxi/patches/240-add-rgl-c64mini.patch [new file with mode: 0644]
target/linux/sunxi/image/cortexa7.mk
target/linux/sunxi/patches-5.10/401-dts-add-rgl-C64mini.patch [new file with mode: 0644]

index d248db886baa6cb51a9bdba38f15c5171d42778d..8bc6cbc1409bcd5697e349a3f4f03c8d3bbe2216 100644 (file)
@@ -334,6 +334,12 @@ define U-Boot/orangepi_pc2
   ATF:=a64
 endef
 
+define U-Boot/rgl_c64mini
+  BUILD_SUBTARGET:=cortexa7
+  NAME:=Retro Games Ltd. C=64 Mini
+  BUILD_DEVICES:=rgl_c64mini
+endef
+
 define U-Boot/Bananapi_M2_Ultra
   BUILD_SUBTARGET:=cortexa7
   NAME:=Bananapi M2 Ultra
@@ -391,6 +397,7 @@ UBOOT_TARGETS := \
        orangepi_pc2 \
        pangolin \
        pine64_plus \
+       rgl_c64mini \
        Sinovoip_BPI_M3 \
        sopine_baseboard \
        orangepi_zero_plus \
diff --git a/package/boot/uboot-sunxi/patches/240-add-rgl-c64mini.patch b/package/boot/uboot-sunxi/patches/240-add-rgl-c64mini.patch
new file mode 100644 (file)
index 0000000..57e1742
--- /dev/null
@@ -0,0 +1,287 @@
+diff -ruN u-boot-2020.04.old/arch/arm/dts/sun7i-a20-rgl-c64mini.dts u-boot-2020.04/arch/arm/dts/sun7i-a20-rgl-c64mini.dts
+--- u-boot-2020.04.old/arch/arm/dts/sun7i-a20-rgl-c64mini.dts  1970-01-01 01:00:00.000000000 +0100
++++ u-boot-2020.04/arch/arm/dts/sun7i-a20-rgl-c64mini.dts      2020-07-07 11:32:47.000000000 +0200
+@@ -0,0 +1,254 @@
++/*
++ * This is based on sun4i-a10-olinuxino-lime.dts
++ *
++ * Copyright 2014 - Hans de Goede <hdegoede@redhat.com>
++ * Copyright (c) 2014 FUKAUMI Naoki <naobsd@gmail.com>
++ *
++ * This file is dual-licensed: you can use it either under the terms
++ * of the GPL or the X11 license, at your option. Note that this dual
++ * licensing only applies to this file, and not this project as a
++ * whole.
++ *
++ *  a) This file is free software; you can redistribute it and/or
++ *     modify it under the terms of the GNU General Public License as
++ *     published by the Free Software Foundation; either version 2 of the
++ *     License, or (at your option) any later version.
++ *
++ *     This file is distributed in the hope that it will be useful,
++ *     but WITHOUT ANY WARRANTY; without even the implied warranty of
++ *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++ *     GNU General Public License for more details.
++ *
++ * Or, alternatively,
++ *
++ *  b) Permission is hereby granted, free of charge, to any person
++ *     obtaining a copy of this software and associated documentation
++ *     files (the "Software"), to deal in the Software without
++ *     restriction, including without limitation the rights to use,
++ *     copy, modify, merge, publish, distribute, sublicense, and/or
++ *     sell copies of the Software, and to permit persons to whom the
++ *     Software is furnished to do so, subject to the following
++ *     conditions:
++ *
++ *     The above copyright notice and this permission notice shall be
++ *     included in all copies or substantial portions of the Software.
++ *
++ *     THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++ *     EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
++ *     OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++ *     NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
++ *     HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
++ *     WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++ *     FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ *     OTHER DEALINGS IN THE SOFTWARE.
++ */
++
++/dts-v1/;
++#include "sun7i-a20.dtsi"
++#include "sunxi-common-regulators.dtsi"
++
++#include <dt-bindings/gpio/gpio.h>
++#include <dt-bindings/interrupt-controller/irq.h>
++
++/ {
++      model = "Retro Games C=64 Mini";
++      compatible = "rgl,c64-mini", "allwinner,sun7i-a20";
++
++      aliases {
++              serial0 = &uart0;
++      };
++
++      chosen {
++              stdout-path = "serial0:115200n8";
++      };
++
++      hdmi-connector {
++              compatible = "hdmi-connector";
++              type = "a";
++
++              port {
++                      hdmi_con_in: endpoint {
++                              remote-endpoint = <&hdmi_out_con>;
++                      };
++              };
++      };
++
++      leds {
++              compatible = "gpio-leds";
++              pinctrl-names = "default";
++              pinctrl-0 = <&led_pins_olinuxinolime>;
++
++              green {
++                      label = "a20-olinuxino-lime:green:usr";
++                      gpios = <&pio 7 2 GPIO_ACTIVE_HIGH>;
++                      default-state = "on";
++              };
++      };
++};
++
++&de {
++      status = "okay";
++};
++
++&ehci0 {
++      status = "okay";
++};
++
++&ehci1 {
++      status = "okay";
++};
++
++&hdmi {
++      status = "okay";
++};
++
++&hdmi_out {
++      hdmi_out_con: endpoint {
++              remote-endpoint = <&hdmi_con_in>;
++      };
++};
++
++&i2c0 {
++      status = "okay";
++
++      axp209: pmic@34 {
++              compatible = "x-powers,axp209";
++              reg = <0x34>;
++              interrupt-parent = <&nmi_intc>;
++              interrupts = <0 IRQ_TYPE_LEVEL_LOW>;
++
++              interrupt-controller;
++              #interrupt-cells = <1>;
++      };
++};
++
++&i2c1 {
++      status = "okay";
++
++      eeprom: eeprom@50 {
++              compatible = "atmel,24c16";
++              reg = <0x50>;
++              pagesize = <16>;
++      };
++};
++
++&mmc0 {
++      vmmc-supply = <&reg_vcc3v3>;
++      bus-width = <4>;
++      cd-gpios = <&pio 7 1 GPIO_ACTIVE_LOW>; /* PH1 */
++      status = "okay";
++};
++
++&ohci0 {
++      status = "okay";
++};
++
++&ohci1 {
++      status = "okay";
++};
++
++&otg_sram {
++      status = "okay";
++};
++
++&pio {
++      led_pins_olinuxinolime: led_pins@0 {
++              pins = "PH2";
++              function = "gpio_out";
++              drive-strength = <20>;
++      };
++
++      usb0_id_detect_pin: usb0_id_detect_pin@0 {
++              pins = "PH4";
++              function = "gpio_in";
++              bias-pull-up;
++      };
++
++      usb0_vbus_detect_pin: usb0_vbus_detect_pin@0 {
++              pins = "PH5";
++              function = "gpio_in";
++              bias-pull-down;
++      };
++
++      nand_pins: nand-pins {
++              pins = "PC0", "PC1", "PC2", "PC5",
++                     "PC8", "PC9", "PC10", "PC11",
++                     "PC12", "PC13", "PC14", "PC15";
++              function = "nand0";
++      };
++
++      nand_pins_cs0: nand-pins-cs0 {
++              pins = "PC4";
++              function = "nand0";
++              bias-pull-up;
++      };
++
++      nand_pins_cs1: nand-pins-cs1 {
++              pins = "PC3";
++              function = "nand0";
++              bias-pull-up;
++      };
++
++      nand_pins_rb0: nand-pins-rb0 {
++              pins = "PC6";
++              function = "nand0";
++              bias-pull-up;
++      };
++
++      nand_pins_rb1: nand-pins-rb1 {
++              pins = "PC7";
++              function = "nand0";
++              bias-pull-up;
++      };
++};
++
++&reg_usb0_vbus {
++      status = "okay";
++};
++
++&reg_usb1_vbus {
++      status = "okay";
++};
++
++&reg_usb2_vbus {
++      status = "okay";
++};
++
++&uart0 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&uart0_pb_pins>;
++      status = "okay";
++};
++
++&usb_otg {
++      dr_mode = "otg";
++      status = "okay";
++};
++
++&usbphy {
++      pinctrl-names = "default";
++      pinctrl-0 = <&usb0_id_detect_pin>, <&usb0_vbus_detect_pin>;
++      usb0_id_det-gpio = <&pio 7 4 GPIO_ACTIVE_HIGH>; /* PH4 */
++      usb0_vbus_det-gpio = <&pio 7 5 GPIO_ACTIVE_HIGH>; /* PH5 */
++      usb0_vbus-supply = <&reg_usb0_vbus>;
++      usb1_vbus-supply = <&reg_usb1_vbus>;
++      usb2_vbus-supply = <&reg_usb2_vbus>;
++      status = "okay";
++};
++
++&nfc {
++      status = "okay";
++      pinctrl-names = "default";
++      pinctrl-0 = <&nand_pins>, <&nand_pins_cs0>, <&nand_pins_rb0>;
++
++      /* ESMT NAND 128MiB 3,3V 8-bit */
++      nand@0 {
++              #address-cells = <1>;
++              #size-cells = <1>;
++              reg = <0>;
++              allwinner,rb = <0>;
++              nand-ecc-mode = "hw";
++              nand-ecc-strength = <16>;
++              nand-ecc-step-size = <1024>;
++      };
++};
+diff -ruN u-boot-2020.04.old/configs/rgl_c64mini_defconfig u-boot-2020.04/configs/rgl_c64mini_defconfig
+--- u-boot-2020.04.old/configs/rgl_c64mini_defconfig   1970-01-01 01:00:00.000000000 +0100
++++ u-boot-2020.04/configs/rgl_c64mini_defconfig       2020-07-07 23:52:25.574583780 +0200
+@@ -0,0 +1,14 @@
++CONFIG_ARM=y
++CONFIG_ARCH_SUNXI=y
++CONFIG_SPL=y
++CONFIG_MACH_SUN7I=y
++CONFIG_DRAM_CLK=384
++CONFIG_MMC0_CD_PIN="PH1"
++CONFIG_I2C1_ENABLE=y
++# CONFIG_SYS_MALLOC_CLEAR_ON_INIT is not set
++CONFIG_SPL_I2C_SUPPORT=y
++CONFIG_DEFAULT_DEVICE_TREE="sun7i-a20-rgl-c64mini"
++CONFIG_AXP_ALDO3_VOLT=2800
++CONFIG_AXP_ALDO4_VOLT=2800
++CONFIG_USB_EHCI_HCD=y
++CONFIG_USB_OHCI_HCD=y
+diff -ruN a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
+--- a/arch/arm/dts/Makefile    2021-01-18 10:07:44.318693224 +0100
++++ b/arch/arm/dts/Makefile    2021-01-18 10:35:00.953333457 +0100
+@@ -491,6 +491,7 @@
+       sun7i-a20-pcduino3.dtb \
+       sun7i-a20-pcduino3-nano.dtb \
+       sun7i-a20-primo73.dtb \
++      sun7i-a20-rgl-c64mini.dtb \
+       sun7i-a20-wexler-tab7200.dtb \
+       sun7i-a20-wits-pro-a20-dkt.dtb \
+       sun7i-a20-yones-toptech-bd1078.dtb
index b84f11599f17d6a5e6ec9df46fe3fb7e6a4c59dc..31d5974cdd9cfbd8e840245516277eb36223e50e 100644 (file)
@@ -185,6 +185,14 @@ define Device/sinovoip_bananapi-m3
 endef
 TARGET_DEVICES += sinovoip_bananapi-m3
 
+define Device/rgl_c64mini
+  DEVICE_VENDOR := Retro Games Limited
+  DEVICE_MODEL := C=64 Mini
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-leds-gpio
+  SOC := sun7i-a20
+endef
+TARGET_DEVICES += rgl_c64mini
+
 define Device/xunlong_orangepi-one
   DEVICE_VENDOR := Xunlong
   DEVICE_MODEL := Orange Pi One
diff --git a/target/linux/sunxi/patches-5.10/401-dts-add-rgl-C64mini.patch b/target/linux/sunxi/patches-5.10/401-dts-add-rgl-C64mini.patch
new file mode 100644 (file)
index 0000000..0bbb371
--- /dev/null
@@ -0,0 +1,220 @@
+diff -ruN a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
+--- a/arch/arm/boot/dts/Makefile       2019-02-06 17:30:16.000000000 +0100
++++ b/arch/arm/boot/dts/Makefile       2019-02-13 17:48:08.493420738 +0100
+@@ -1006,6 +1006,7 @@
+       sun7i-a20-orangepi-mini.dtb \
+       sun7i-a20-pcduino3.dtb \
+       sun7i-a20-pcduino3-nano.dtb \
++      sun7i-a20-c64mini.dtb \
+       sun7i-a20-wexler-tab7200.dtb \
+       sun7i-a20-wits-pro-a20-dkt.dtb
+ dtb-$(CONFIG_MACH_SUN8I) += \
+diff -ruN a/arch/arm/boot/dts/sun7i-a20-c64mini.dts b/arch/arm/boot/dts/sun7i-a20-c64mini.dts
+--- a/arch/arm/boot/dts/sun7i-a20-c64mini.dts  1970-01-01 01:00:00.000000000 +0100
++++ b/arch/arm/boot/dts/sun7i-a20-c64mini.dts  2019-02-13 17:54:22.550445293 +0100
+@@ -0,0 +1,205 @@
++/*
++ * This is based on sun4i-a10-olinuxino-lime.dts
++ *
++ * Copyright 2014 - Hans de Goede <hdegoede@redhat.com>
++ * Copyright (c) 2014 FUKAUMI Naoki <naobsd@gmail.com>
++ * Copyright (c) 2020 Zoltan HERPAI <wigyori@uid0.hu
++ *
++ * This file is dual-licensed: you can use it either under the terms
++ * of the GPL or the X11 license, at your option. Note that this dual
++ * licensing only applies to this file, and not this project as a
++ * whole.
++ *
++ *  a) This file is free software; you can redistribute it and/or
++ *     modify it under the terms of the GNU General Public License as
++ *     published by the Free Software Foundation; either version 2 of the
++ *     License, or (at your option) any later version.
++ *
++ *     This file is distributed in the hope that it will be useful,
++ *     but WITHOUT ANY WARRANTY; without even the implied warranty of
++ *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++ *     GNU General Public License for more details.
++ *
++ * Or, alternatively,
++ *
++ *  b) Permission is hereby granted, free of charge, to any person
++ *     obtaining a copy of this software and associated documentation
++ *     files (the "Software"), to deal in the Software without
++ *     restriction, including without limitation the rights to use,
++ *     copy, modify, merge, publish, distribute, sublicense, and/or
++ *     sell copies of the Software, and to permit persons to whom the
++ *     Software is furnished to do so, subject to the following
++ *     conditions:
++ *
++ *     The above copyright notice and this permission notice shall be
++ *     included in all copies or substantial portions of the Software.
++ *
++ *     THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++ *     EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
++ *     OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++ *     NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
++ *     HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
++ *     WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++ *     FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ *     OTHER DEALINGS IN THE SOFTWARE.
++ */
++
++/dts-v1/;
++#include "sun7i-a20.dtsi"
++#include "sunxi-common-regulators.dtsi"
++
++#include <dt-bindings/gpio/gpio.h>
++#include <dt-bindings/interrupt-controller/irq.h>
++
++/ {
++      model = "Retro Games C=64 Mini";
++      compatible = "rgl,c64-mini", "allwinner,sun7i-a20";
++
++      aliases {
++              serial0 = &uart0;
++      };
++
++      chosen {
++              stdout-path = "serial0:115200n8";
++      };
++
++      hdmi-connector {
++              compatible = "hdmi-connector";
++              type = "a";
++
++              port {
++                      hdmi_con_in: endpoint {
++                              remote-endpoint = <&hdmi_out_con>;
++                      };
++              };
++      };
++
++      leds {
++              compatible = "gpio-leds";
++              pinctrl-names = "default";
++              pinctrl-0 = <&led_pins_olinuxinolime>;
++
++              green {
++                      label = "a20-olinuxino-lime:green:usr";
++                      gpios = <&pio 7 2 GPIO_ACTIVE_HIGH>;
++                      default-state = "on";
++              };
++      };
++};
++
++&de {
++      status = "okay";
++};
++
++&ehci0 {
++      status = "okay";
++};
++
++&ehci1 {
++      status = "okay";
++};
++
++&hdmi {
++      status = "okay";
++};
++
++&hdmi_out {
++      hdmi_out_con: endpoint {
++              remote-endpoint = <&hdmi_con_in>;
++      };
++};
++
++&i2c0 {
++      status = "okay";
++
++      axp209: pmic@34 {
++              compatible = "x-powers,axp209";
++              reg = <0x34>;
++              interrupt-parent = <&nmi_intc>;
++              interrupts = <0 IRQ_TYPE_LEVEL_LOW>;
++
++              interrupt-controller;
++              #interrupt-cells = <1>;
++      };
++};
++
++&i2c1 {
++      status = "okay";
++
++      eeprom: eeprom@50 {
++              compatible = "atmel,24c16";
++              reg = <0x50>;
++              pagesize = <16>;
++      };
++};
++
++&mmc0 {
++      vmmc-supply = <&reg_vcc3v3>;
++      bus-width = <4>;
++      cd-gpios = <&pio 7 1 GPIO_ACTIVE_LOW>; /* PH1 */
++      status = "okay";
++};
++
++&ohci0 {
++      status = "okay";
++};
++
++&ohci1 {
++      status = "okay";
++};
++
++&otg_sram {
++      status = "okay";
++};
++
++&pio {
++      led_pins_olinuxinolime: led_pins@0 {
++              pins = "PH2";
++              function = "gpio_out";
++              drive-strength = <20>;
++      };
++
++      usb0_id_detect_pin: usb0_id_detect_pin@0 {
++              pins = "PH4";
++              function = "gpio_in";
++              bias-pull-up;
++      };
++
++      usb0_vbus_detect_pin: usb0_vbus_detect_pin@0 {
++              pins = "PH5";
++              function = "gpio_in";
++              bias-pull-down;
++      };
++};
++
++&reg_usb0_vbus {
++      status = "okay";
++};
++
++&reg_usb1_vbus {
++      status = "okay";
++};
++
++&reg_usb2_vbus {
++      status = "okay";
++};
++
++&uart0 {
++      status = "okay";
++};
++
++&usb_otg {
++      dr_mode = "otg";
++      status = "okay";
++};
++
++&usbphy {
++      pinctrl-names = "default";
++      pinctrl-0 = <&usb0_id_detect_pin>, <&usb0_vbus_detect_pin>;
++      usb0_id_det-gpio = <&pio 7 4 GPIO_ACTIVE_HIGH>; /* PH4 */
++      usb0_vbus_det-gpio = <&pio 7 5 GPIO_ACTIVE_HIGH>; /* PH5 */
++      usb0_vbus-supply = <&reg_usb0_vbus>;
++      usb1_vbus-supply = <&reg_usb1_vbus>;
++      usb2_vbus-supply = <&reg_usb2_vbus>;
++      status = "okay";
++};