realtek: rename cameo specific names in "Build/*" definitions
authorINAGAKI Hiroshi <musashino.open@gmail.com>
Fri, 7 Oct 2022 16:07:17 +0000 (01:07 +0900)
committerSander Vanheule <sander@svanheule.net>
Mon, 13 Feb 2023 11:22:17 +0000 (12:22 +0100)
This patch renames some Cameo specific definitions for image generation.
The same format is also used on APRESIA ApresiaLightGS series devices, not
D-Link specific.

Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
target/linux/realtek/image/Makefile
target/linux/realtek/image/common.mk

index a2afb39d406a441ea1471baf5691a0e9e57ab277..f50821d24ae7d14f07f64befd7f3f31544279357 100644 (file)
@@ -9,8 +9,8 @@ DEVICE_VARS += \
         CAMEO_BOARD_VERSION \
         CAMEO_CUSTOMER_SIGNATURE \
         CAMEO_KERNEL_PART \
+        CAMEO_KERNEL_PART_SIZE \
         CAMEO_ROOTFS_PART \
-        DLINK_KERNEL_PART_SIZE \
         H3C_DEVICE_ID \
         H3C_PRODUCT_ID \
         ZYXEL_VERS
@@ -23,18 +23,18 @@ define Build/zyxel-vers
        done ) >> $@
 endef
 
-define Build/dlink-cameo
-       $(SCRIPT_DIR)/cameo-tag.py $@ $(DLINK_KERNEL_PART_SIZE)
+define Build/cameo-tag
+       $(SCRIPT_DIR)/cameo-tag.py $@ $(CAMEO_KERNEL_PART_SIZE)
 endef
 
-define Build/dlink-version
+define Build/cameo-version
        echo -n "OpenWrt" >> $@
        dd if=/dev/zero bs=25 count=1 >> $@
 endef
 
-define Build/dlink-headers
-        dd if=$@ bs=$(DLINK_KERNEL_PART_SIZE) count=1 of=$@.kernel_part; \
-        dd if=$@ bs=$(DLINK_KERNEL_PART_SIZE) skip=1 of=$@.rootfs_part; \
+define Build/cameo-headers
+        dd if=$@ bs=$(CAMEO_KERNEL_PART_SIZE) count=1 of=$@.kernel_part; \
+        dd if=$@ bs=$(CAMEO_KERNEL_PART_SIZE) skip=1 of=$@.rootfs_part; \
         $(SCRIPT_DIR)/cameo-imghdr.py $@.kernel_part $@.kernel_part.hex \
                 "$(DEVICE_MODEL)" os $(CAMEO_KERNEL_PART) \
                 $(CAMEO_CUSTOMER_SIGNATURE) \
index 214683f8e95923794753cf5b569d39975fad2c9a..1a1d6356a767e0d2be411d41697912ae2bbd7479 100644 (file)
@@ -9,7 +9,7 @@ define Device/d-link_dgs-1210
        append-dtb | \
        libdeflate-gzip | \
        uImage gzip | \
-       dlink-cameo
+       cameo-tag
   CAMEO_KERNEL_PART := 2
   CAMEO_ROOTFS_PART := 3
   CAMEO_CUSTOMER_SIGNATURE := 2
@@ -22,8 +22,8 @@ define Device/d-link_dgs-1210
        pad-rootfs | \
        pad-to 16 | \
        check-size | \
-       dlink-version | \
-       dlink-headers
+       cameo-version | \
+       cameo-headers
 endef
 
 define Device/hpe_1920