lantiq: move DTS_DIR variable out of Device definition
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 24 Jan 2020 17:35:25 +0000 (18:35 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 24 Jan 2020 17:35:25 +0000 (18:35 +0100)
The DTS_DIR variable is not a device variable, thus it should not
be set inside Device/Default but globally.

Fixes: c640370939d7 ("lantiq: use soc_vendor_device scheme on DTS file")
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/lantiq/image/Makefile

index 3060ff920b9a25c417c0ae27f05edc8fd614efa0..68de191283af9afb458cd272a73969dcadf277a5 100644 (file)
@@ -52,6 +52,8 @@ define Build/fullimage
        rm $@.tmp
 endef
 
+DTS_DIR := $(DTS_DIR)/lantiq
+
 # Shared device definition: applies to every defined device
 define Device/Default
   PROFILES = Default
@@ -61,7 +63,6 @@ define Device/Default
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
   FILESYSTEMS := squashfs
   IMAGE_SIZE :=
-  DTS_DIR := $(DTS_DIR)/lantiq
   DEVICE_DTS = $$(SOC)_$(1)
   SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   IMAGES := sysupgrade.bin