ixp4xx/apex: Limit ram size to 64MB
authorRod Whitby <rod@whitby.id.au>
Sat, 6 Dec 2008 13:19:15 +0000 (13:19 +0000)
committerRod Whitby <rod@whitby.id.au>
Sat, 6 Dec 2008 13:19:15 +0000 (13:19 +0000)
SVN-Revision: 13530

target/linux/ixp4xx/image/apex/Makefile
target/linux/ixp4xx/image/apex/patches/150-limit_ram_to_64mb.patch [new file with mode: 0644]

index fdb2a054e6825af379284718aacc351c726ffa38..d6c4c4a0c22ea978cd9f3c38de69287c1ff76b30 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apex
 PKG_VERSION:=1.5.14
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/target/linux/ixp4xx/image/apex/patches/150-limit_ram_to_64mb.patch b/target/linux/ixp4xx/image/apex/patches/150-limit_ram_to_64mb.patch
new file mode 100644 (file)
index 0000000..79ecd97
--- /dev/null
@@ -0,0 +1,22 @@
+--- apex-1.5.13/src/mach-ixp42x/slugos-nslu2-armeb_config~     2008-11-28 14:05:56.905634749 +0000
++++ apex-1.5.13/src/mach-ixp42x/slugos-nslu2-armeb_config      2008-12-06 13:15:49.857504031 +0000
+@@ -135,7 +135,7 @@
+ CONFIG_ENV_STARTUP_KERNEL_COPY=y
+ # CONFIG_ENV_REGION_KERNEL_SWAP is not set
+ CONFIG_ENV_STARTUP_PREFIX_P=y
+-CONFIG_ENV_STARTUP_PREFIX="sdram-init; memscan -u 0+256m"
++CONFIG_ENV_STARTUP_PREFIX="sdram-init; memscan -u 0+64m"
+ #
+ #    Regions
+--- apex-1.5.13/src/mach-ixp42x/slugos-nslu2-16mb-armeb_config~        2008-11-28 14:05:56.905634749 +0000
++++ apex-1.5.13/src/mach-ixp42x/slugos-nslu2-16mb-armeb_config 2008-12-06 13:17:41.311867740 +0000
+@@ -135,7 +135,7 @@
+ CONFIG_ENV_STARTUP_KERNEL_COPY=y
+ # CONFIG_ENV_REGION_KERNEL_SWAP is not set
+ CONFIG_ENV_STARTUP_PREFIX_P=y
+-CONFIG_ENV_STARTUP_PREFIX="sdram-init; memscan -u 0+256m"
++CONFIG_ENV_STARTUP_PREFIX="sdram-init; memscan -u 0+64m"
+ #
+ #    Regions