sunxi: Added support for Xunlong Orange Pi PC2
authorAntonio Silverio <menion@gmail.com>
Mon, 30 Jul 2018 09:33:03 +0000 (11:33 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Thu, 9 Aug 2018 10:06:58 +0000 (12:06 +0200)
CPU: H5 High Performance Quad-core 64-bit Cortex-A53
GPU: Mali450 OpenGL ES 2.0/1.1/1.0, OpenVG 1.1, EGL
Memory: 1GB DDR3 (shared with GPU)
Onboard Storage: TF card (Max. 32GB) / NOR flash(2MB)
Onboard Network: 1000M/100M Ethernet RJ45
USB 2.0 Ports: Three USB 2.0 HOST, one USB 2.0 OTG, HOST mode
role by default in DTS
Buttons: Power Button(SW4) Debug TTL

UART: ..DC-IN..
>[GND][RX][TX] ..HDMI..

Signed-off-by: Antonio Silverio <menion@gmail.com>
package/boot/uboot-sunxi/Makefile
target/linux/sunxi/image/cortex-a53.mk

index 7773e340c139e71acad07d9472688f8efba02007..ce5edfc1b62c4b7833e58e3ac257f9d633bbfed5 100644 (file)
@@ -207,6 +207,14 @@ define U-Boot/orangepi_zero_plus
   UENV:=a64
 endef
 
+define U-Boot/orangepi_pc2
+  BUILD_SUBTARGET:=cortexa53
+  NAME:=Xunlong Orange Pi PC2
+  BUILD_DEVICES:=sun50i-h5-orangepi-pc2
+  DEPENDS:=+PACKAGE_u-boot-orangepi_pc2:arm-trusted-firmware-sunxi
+  UENV:=a64
+endef
+
 UBOOT_TARGETS := \
        A10-OLinuXino-Lime \
        A13-OLinuXino \
@@ -233,6 +241,7 @@ UBOOT_TARGETS := \
        orangepi_pc \
        orangepi_plus \
        orangepi_2 \
+       orangepi_pc2 \
        pangolin \
        pine64_plus \
        sopine_baseboard \
index 344071b94d2f00b805f84c108e9f117e0bf1ff25..e40f35cb32674ff1f68ecbac75352a0d4ed31607 100644 (file)
@@ -48,4 +48,14 @@ endef
 
 TARGET_DEVICES += sun50i-h5-orangepi-zero-plus
 
+define Device/sun50i-h5-orangepi-pc2
+  DEVICE_TITLE:=Xunlong Orange Pi PC2
+  SUPPORTED_DEVICES:=xunlong,orangepi-pc2
+  SUNXI_DTS:=allwinner/sun50i-h5-orangepi-pc2
+  KERNEL_NAME := Image
+  KERNEL := kernel-bin
+endef
+
+TARGET_DEVICES += sun50i-h5-orangepi-pc2
+
 endif