libiconv-full: fix compile-time linking error GCC7
authorJake Staehle <jacob@staehle.us>
Tue, 24 Oct 2017 18:09:37 +0000 (13:09 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 19 Dec 2017 21:23:42 +0000 (22:23 +0100)
LEDE Flyspray Task 1091:
Fix libiconv-full 'undefined reference' compile linker error using GCC7 Musl
Tested with targets x86 (i386 and x86_64)
Addition of CFLAGS "std=gnu89" fixes the linker issues, credit to harrylwc
Issue found with 'minidlna' package, which depends on 'libiconv-full'
Error in compile log:
../lib/.libs/libiconv.so: undefined reference to `aliases_lookup'
../lib/.libs/libiconv.so: undefined reference to `aliases2_lookup'
collect2: error: ld returned 1 exit status
Makefile:64: recipe for target 'iconv_no_i18n' failed

Signed-off-by: Jake Staehle <jacob@staehle.us>
package/libs/libiconv-full/Makefile

index 9776711a79b85ed59f07021384f6a2601ef2c4cc..ac7bfddf561227b87bc2cc8979eb86bf1a374666 100644 (file)
@@ -51,7 +51,7 @@ define Package/iconv
   TITLE+= utility
 endef
 
-TARGET_CFLAGS += $(FPIC) -DUSE_DOS
+TARGET_CFLAGS += $(FPIC) -DUSE_DOS -std=gnu89
 
 CONFIGURE_ARGS += \
        --enable-shared \