brcm63xx: hcsimage: respect load address
authorJonas Gorski <jogo@openwrt.org>
Wed, 25 Mar 2015 15:34:45 +0000 (15:34 +0000)
committerJonas Gorski <jogo@openwrt.org>
Wed, 25 Mar 2015 15:34:45 +0000 (15:34 +0000)
Respect the vmlinux load address when generating images.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 44983

target/linux/brcm63xx/image/Makefile

index 1913feb6469635a642ff831494f80bd5c2a79463..47756bf39b5c896a1690bbb9c5a7ee92dca16738 100755 (executable)
@@ -119,7 +119,8 @@ define Image/Build/HCSDTB
        # Generate the image
        $(STAGING_DIR_HOST)/bin/hcsmakeimage --magic_byte=$(4) \
                --rev_maj=$(5) --rev_min=$(6) --input_file=$(KDIR)/$(7) \
-               --output_file=$(BIN_DIR)/openwrt-$(2)-$(1).bin
+               --output_file=$(BIN_DIR)/openwrt-$(2)-$(1).bin \
+               --ldaddress=$(LOADADDR)
 endef
 
 define Image/Build/ChkDTB