ramips: Support for Teltonika RUT5XX
authorJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:42:48 +0000 (12:42 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:42:48 +0000 (12:42 +0000)
Hi Hartmut,

Thanks for your feedback, I have reformated the patch accordingly.

Added support for Teltonika RUT5XX hardware.

Signed-off-by: Steffen Weinreich <steve@weinreich.org>
SVN-Revision: 40907

target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/RUT5XX.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index 075562af023e77c5428b0a80dd234dc1ddcef816..66a0aaae47a6b496667e14834851d800d7e0bff5 100755 (executable)
@@ -104,6 +104,9 @@ get_status_led() {
        rt-n56u | wl-330n | wl-330n3g)
                status_led="asus:blue:power"
                ;;
+       rut5xx)
+               status_led="rut5xx:green:status"
+               ;;
        sl-r7205)
                status_led="sl-r7205:green:status"
                ;;
index 341fd5f4d1dd37d20f665e998440728f5193cf9b..1a39bb6035160434f0a156b1786e46b84de2373b 100644 (file)
@@ -97,6 +97,7 @@ case "$FIRMWARE" in
        px4885 | \
        rt-n15 | \
        rt-n56u | \
+       rut5xx | \
        sl-r7205 | \
        v11st-fe | \
        v22rw-2x2 | \
index 7f221f807d2672cc4882a3dfef94bc0e9b457f07..4619befb29726e63a02f88cb8496742e2223f18c 100755 (executable)
@@ -211,6 +211,9 @@ ramips_board_detect() {
        *"RT-N56U")
                name="rt-n56u"
                ;;
+       *"RUT5XX")
+               name="rut5xx"
+               ;;
        *"Skyline SL-R7205"*)
                name="sl-r7205"
                ;;
index d8098b2a6655a4b380d85669516edcd33929131f..c85ee0f703c6852f331edf0e1489d414c713314b 100755 (executable)
@@ -69,6 +69,7 @@ platform_check_image() {
        rt-n14u | \
        rt-n15 | \
        rt-n56u | \
+       rut5xx | \
        sl-r7205 | \
        tew-691gr | \
        tew-692gr | \
diff --git a/target/linux/ramips/dts/RUT5XX.dts b/target/linux/ramips/dts/RUT5XX.dts
new file mode 100644 (file)
index 0000000..530b8b1
--- /dev/null
@@ -0,0 +1,86 @@
+/dts-v1/;
+
+/include/ "rt3050.dtsi"
+
+/ {
+       compatible = "RUT5XX", "ralink,rt3050-soc";
+       model = "Teltonika RUT5XX";
+
+       palmbus@10000000 {
+               spi@b00 {
+                       status = "okay";
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "n25q128a13";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "n25q128a13";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0xfb0000>;
+                               };
+                       };
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "jtag", "rgmii", "mdio", "uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+        ethernet@10100000 {
+                mtd-mac-address = <&factory 0x28>;
+        };
+
+       esw@10110000 {
+               ralink,portmap = <0x3e>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               status {
+                       label = "rut5xx:green:status";
+                       gpios = <&gpio0 14 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 10 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       otg@101c0000 {
+               status = "okay";
+       };
+};
index 19932f6fe19bb584bdadb65ca7febac1d9a9b9f2..345b85003fac1f346a97f436dbc2f00ce337bd2f 100644 (file)
@@ -454,6 +454,8 @@ Image/Build/Profile/RTG32B1=$(call BuildFirmware/Default4M/$(1),$(1),rt-g32-b1,R
 
 Image/Build/Profile/RTN10PLUS=$(call BuildFirmware/Default4M/$(1),$(1),rt-n10-plus,RT-N10-PLUS)
 
+Image/Build/Profile/RUT5XX=$(call BuildFirmware/Default8M/$(1),$(1),rut5xx,RUT5XX)
+
 Image/Build/Profile/SL-R7205=$(call BuildFirmware/Default4M/$(1),$(1),sl-r7205,SL-R7205)
 
 Image/Build/Profile/V22RW-2X2=$(call BuildFirmware/Default4M/$(1),$(1),v22rw-2x2,V22RW-2X2)
@@ -591,6 +593,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/RTG32B1,$(1))
        $(call Image/Build/Profile/RTN10PLUS,$(1))
        $(call Image/Build/Profile/RT-N13U,$(1))
+       $(call Image/Build/Profile/RUT5XX,$(1))
        $(call Image/Build/Profile/SL-R7205,$(1))
        $(call Image/Build/Profile/UR-326N4G,$(1))
        $(call Image/Build/Profile/V22RW-2X2,$(1))