ixp4xx: add missing reboot handlers (fixes #11577)
authorFelix Fietkau <nbd@openwrt.org>
Tue, 9 Oct 2012 15:38:55 +0000 (15:38 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 9 Oct 2012 15:38:55 +0000 (15:38 +0000)
SVN-Revision: 33672

12 files changed:
target/linux/ixp4xx/patches-3.3/105-wg302v1_support.patch
target/linux/ixp4xx/patches-3.3/110-pronghorn_series_support.patch
target/linux/ixp4xx/patches-3.3/115-sidewinder_support.patch
target/linux/ixp4xx/patches-3.3/120-compex_support.patch
target/linux/ixp4xx/patches-3.3/130-wrt300nv2_support.patch
target/linux/ixp4xx/patches-3.3/150-lanready_ap1000_support.patch
target/linux/ixp4xx/patches-3.3/160-delayed_uart_io.patch
target/linux/ixp4xx/patches-3.3/180-tw5334_support.patch
target/linux/ixp4xx/patches-3.3/185-mi424wr_support.patch
target/linux/ixp4xx/patches-3.3/190-cambria_support.patch
target/linux/ixp4xx/patches-3.3/500-usr8200_support.patch
target/linux/ixp4xx/patches-3.3/520-tw2662_support.patch

index 1e8fdaa513a9be580041b08f637c5bb83b95e2df..c9d5b9421a0a9be00c6758d6d7982c7cdd27173a 100644 (file)
 +subsys_initcall(wg302v1_pci_init);
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/wg302v1-setup.c
-@@ -0,0 +1,144 @@
+@@ -0,0 +1,145 @@
 +/*
 + * arch/arm/mach-ixp4xx/wg302v1-setup.c
 + *
 +#if defined(CONFIG_PCI)
 +      .dma_zone_size  = SZ_64M,
 +#endif
++      .restart        = ixp4xx_restart,
 +MACHINE_END
 +#endif
index 529cddb4369689a49fe8510b6c7f2b82f3a685ae..f795fb576d6aa582cff2983debe94beb725808da 100644 (file)
 +subsys_initcall(pronghorn_pci_init);
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/pronghorn-setup.c
-@@ -0,0 +1,247 @@
+@@ -0,0 +1,249 @@
 +/*
 + * arch/arm/mach-ixp4xx/pronghorn-setup.c
 + *
 +#if defined(CONFIG_PCI)
 +      .dma_zone_size  = SZ_64M,
 +#endif
++      .restart        = ixp4xx_restart,
 +MACHINE_END
 +
 +MACHINE_START(PRONGHORNMETRO, "ADI Engineering Pronghorn Metro")
 +#if defined(CONFIG_PCI)
 +      .dma_zone_size  = SZ_64M,
 +#endif
++      .restart        = ixp4xx_restart,
 +MACHINE_END
 --- a/arch/arm/mach-ixp4xx/include/mach/uncompress.h
 +++ b/arch/arm/mach-ixp4xx/include/mach/uncompress.h
index f2e626d16ab15de0f0740c413cac31d5f68e159a..0ffd839736fad18921f9b0745e33b0805e9c51bb 100644 (file)
@@ -130,7 +130,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 +subsys_initcall(sidewinder_pci_init);
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/sidewinder-setup.c
-@@ -0,0 +1,150 @@
+@@ -0,0 +1,151 @@
 +/*
 + * arch/arm/mach-ixp4xx/sidewinder-setup.c
 + *
@@ -280,4 +280,5 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 +#if defined(CONFIG_PCI)
 +      .dma_zone_size  = SZ_64M,
 +#endif
++      .restart        = ixp4xx_restart,
 +MACHINE_END
index da59f4c075c681f89d9fa09197e8593f4a300c18..3166f6722067f5afd64bdda63084dcc6d6a866df 100644 (file)
@@ -50,7 +50,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
  obj-$(CONFIG_IXP4XX_QMGR)     += ixp4xx_qmgr.o
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/compex-setup.c
-@@ -0,0 +1,137 @@
+@@ -0,0 +1,138 @@
 +/*
 + * arch/arm/mach-ixp4xx/compex-setup.c
 + *
@@ -187,6 +187,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 +#if defined(CONFIG_PCI)
 +      .dma_zone_size  = SZ_64M,
 +#endif
++      .restart        = ixp4xx_restart,
 +MACHINE_END
 --- a/arch/arm/mach-ixp4xx/ixdp425-pci.c
 +++ b/arch/arm/mach-ixp4xx/ixdp425-pci.c
index caa2b3887e9a53573f811cce000be25a3dde80a5..638af2903133ad9eb573a7421c03424beb70eec6 100644 (file)
 +subsys_initcall(wrt300nv2_pci_init);
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/wrt300nv2-setup.c
-@@ -0,0 +1,109 @@
+@@ -0,0 +1,110 @@
 +/*
 + * arch/arm/mach-ixp4xx/wrt300nv2-setup.c
 + *
 +#if defined(CONFIG_PCI)
 +      .dma_zone_size  = SZ_64M,
 +#endif
++      .restart        = ixp4xx_restart,
 +MACHINE_END
 +#endif
 --- a/arch/arm/mach-ixp4xx/include/mach/uncompress.h
index da3c1432f3c5a43ae6e8d4b6d0a7cca51b837211..c2b25b3cb73a48902742fa862c988a997677d166 100644 (file)
@@ -1,6 +1,6 @@
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/ap1000-setup.c
-@@ -0,0 +1,152 @@
+@@ -0,0 +1,153 @@
 +/*
 + * arch/arm/mach-ixp4xx/ap1000-setup.c
 + *
 +#if defined(CONFIG_PCI)
 +      .dma_zone_size  = SZ_64M,
 +#endif
++      .restart        = ixp4xx_restart,
 +MACHINE_END
 +#endif
 --- a/arch/arm/mach-ixp4xx/ixdp425-pci.c
index a3b1f25e5b49ec7dc34a119531ece459395c8503..18d93979dfb7826cee52d59a2888cc92322573d4 100644 (file)
@@ -112,7 +112,7 @@ Add a new UART I/O type for slow busses such as the ixp4xx expansion bus
        case UPIO_MEM:
        case UPIO_MEM32:
        case UPIO_AU:
-@@ -2435,6 +2436,7 @@ int uart_match_port(struct uart_port *po
+@@ -2436,6 +2437,7 @@ int uart_match_port(struct uart_port *po
        case UPIO_HUB6:
                return (port1->iobase == port2->iobase) &&
                       (port1->hub6   == port2->hub6);
index 2b6f0f0498df20cbaacb8088a6b532d168ce9e91..7d5a6f22031187c2f0f0074086628d44c66baa07 100644 (file)
@@ -35,7 +35,7 @@
  obj-$(CONFIG_IXP4XX_QMGR)     += ixp4xx_qmgr.o
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/tw5334-setup.c
-@@ -0,0 +1,164 @@
+@@ -0,0 +1,165 @@
 +/*
 + * arch/arm/mach-ixp4xx/tw5334-setup.c
 + *
 +#if defined(CONFIG_PCI)
 +      .dma_zone_size  = SZ_64M,
 +#endif
++      .restart        = ixp4xx_restart,
 +MACHINE_END
 +#endif
 --- /dev/null
index 08ad726407018e3e48fb6c2cb72a0325d727f77c..4d61cee7a1ce2185abd6983b98b8aaaaa2e1b71e 100644 (file)
@@ -74,7 +74,7 @@
 +
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/mi424wr-setup.c
-@@ -0,0 +1,380 @@
+@@ -0,0 +1,381 @@
 +/*
 + * arch/arm/mach-ixp4xx/mi424wr-setup.c
 + *
 +#if defined(CONFIG_PCI)
 +      .dma_zone_size  = SZ_64M,
 +#endif
++      .restart        = ixp4xx_restart,
 +MACHINE_END
 +
 --- a/arch/arm/mach-ixp4xx/Makefile
index 6cee21e89e97842311ed4abfe0062742f0437a34..57dfdace8efc7b45de8db1b852670b8871d45448 100644 (file)
@@ -82,7 +82,7 @@
 +subsys_initcall(cambria_pci_init);
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/cambria-setup.c
-@@ -0,0 +1,1005 @@
+@@ -0,0 +1,1006 @@
 +/*
 + * arch/arm/mach-ixp4xx/cambria-setup.c
 + *
 +#if defined(CONFIG_PCI)
 +      .dma_zone_size  = SZ_64M,
 +#endif
++      .restart        = ixp4xx_restart,
 +MACHINE_END
 --- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
index 8ce1b412939ba0efe7a2e53aa81b11f33b34c8d6..38a63889710e7c8a36702f4643fe7feda08c685e 100644 (file)
 +subsys_initcall(usr8200_pci_init);
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/usr8200-setup.c
-@@ -0,0 +1,213 @@
+@@ -0,0 +1,214 @@
 +/*
 + * arch/arm/mach-ixp4xx/usr8200-setup.c
 + *
 +#if defined(CONFIG_PCI)
 +      .dma_zone_size  = SZ_64M,
 +#endif
++      .restart        = ixp4xx_restart,
 +MACHINE_END
 --- a/arch/arm/mach-ixp4xx/include/mach/uncompress.h
 +++ b/arch/arm/mach-ixp4xx/include/mach/uncompress.h
index edce4771bfff5589302fbdf30e85f32bec0b9ff7..c7940a76965b26ffb5a0c402d290faa279aa0595 100644 (file)
 +subsys_initcall(tw2662_pci_init);
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/tw2662-setup.c
-@@ -0,0 +1,212 @@
+@@ -0,0 +1,213 @@
 +/*
 + * arch/arm/mach-ixp4xx/tw2662-setup.c
 + *
 +#if defined(CONFIG_PCI)
 +      .dma_zone_size  = SZ_64M,
 +#endif
++      .restart        = ixp4xx_restart,
 +MACHINE_END
 +#endif