image: add magic number option for append-uImage-fakehdr
authorMichal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
Fri, 11 Oct 2019 08:52:39 +0000 (10:52 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 21 Oct 2019 11:27:12 +0000 (13:27 +0200)
'append-uImage-fakehdr' can now accept magic number as a second, optional
parameter (passed directly to 'mkimage' command with '-M' option). This
enables construction of proper Netgear-specific fake rootfs images
(required for flashing WNDR4300 for example).

Signed-off-by: Michal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
include/image-commands.mk

index 1d0aed1918f53199357512167ba1b19968c0731c..5dfd6a2c2fd464821081b7ffc1070b9f8ada7ca8 100644 (file)
@@ -109,10 +109,13 @@ endef
 # append a fake/empty uImage header, to fool bootloaders rootfs integrity check
 # for example
 define Build/append-uImage-fakehdr
+       $(eval type=$(word 1,$(1)))
+       $(eval magic=$(word 2,$(1)))
        touch $@.fakehdr
        $(STAGING_DIR_HOST)/bin/mkimage \
-               -A $(LINUX_KARCH) -O linux -T $(1) -C none \
-               -n '$(VERSION_DIST) fake $(1)' \
+               -A $(LINUX_KARCH) -O linux -T $(type) -C none \
+               -n '$(VERSION_DIST) fake $(type)' \
+               $(if $(magic),-M $(magic)) \
                -d $@.fakehdr \
                -s \
                $@.fakehdr