build: prevent spurious host-build re-builds by touching .built after the install...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 15 Dec 2014 20:14:27 +0000 (20:14 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 15 Dec 2014 20:14:27 +0000 (20:14 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 43721

include/host-build.mk

index 126671a0b3d3ce8718c19b022efaf64602ce647a..ad821f72c41a23e6e35704e07a51ee7818e76cfb 100644 (file)
@@ -174,6 +174,7 @@ ifndef DUMP
                $(call Host/Install)
                $(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
                mkdir -p $$(shell dirname $$@)
+               touch $(HOST_STAMP_BUILT)
                touch $$@
 
   ifndef STAMP_BUILT