override default configure to use --target=host and --build=host (closes: #760)
authorNicolas Thill <nico@openwrt.org>
Sun, 10 Sep 2006 09:56:42 +0000 (09:56 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 10 Sep 2006 09:56:42 +0000 (09:56 +0000)
SVN-Revision: 4779

openwrt/toolchain/ext2fs/Makefile

index 0bd24f8fa9129aad72608f44b42024147e84ff14..eebf7a2c88e4b86ae413f58dc809fd8bd579c051 100644 (file)
@@ -19,6 +19,27 @@ PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/host-build.mk
 
+define Build/Configure
+       ( cd $(PKG_BUILD_DIR); \
+               ./configure \
+                       --target=$(GNU_HOST_NAME) \
+                       --host=$(GNU_HOST_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --sbindir=/usr/sbin \
+                       --libexecdir=/usr/lib \
+                       --sysconfdir=/etc \
+                       --datadir=/usr/share \
+                       --localstatedir=/var \
+                       --mandir=/usr/man \
+                       --infodir=/usr/info \
+       )
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) all
 endef