build: do not require git/rsync for ImageBuilder
authorPaul Spooren <mail@aparcar.org>
Fri, 24 Sep 2021 01:30:32 +0000 (15:30 -1000)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 5 Jul 2022 23:17:52 +0000 (01:17 +0200)
The ImageBuilder does not need git or rsync since it only glues files
together, packages are downloaded via wget and not rsync.

Signed-off-by: Paul Spooren <mail@aparcar.org>
[ solve conflict with additional git prereq test ]
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
include/prereq-build.mk

index 80d549af39ba8002a7a2be25e03fcca39fdaa1a8..7428c21e16237e4ccc9f0b52d7c0fbf713a6eb38 100644 (file)
@@ -53,6 +53,13 @@ $(eval $(call TestHostCommand,ncurses, \
        Please install ncurses. (Missing libncurses.so or ncurses.h), \
        echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
                gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
+
+$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
+       git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule, \
+       git submodule --help | grep -- --recursive))
+
+$(eval $(call SetupHostCommand,rsync,Please install 'rsync', \
+       rsync --version </dev/null))
 endif # IB
 
 ifeq ($(HOST_OS),Linux)
@@ -181,16 +188,9 @@ $(eval $(call TestHostCommand,python3-distutils, \
        Please install the Python3 distutils module, \
        $(STAGING_DIR_HOST)/bin/python3 -c 'import distutils'))
 
-$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
-       git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule, \
-       git submodule --help | grep -- --recursive))
-
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version 2>&1 | grep file))
 
-$(eval $(call SetupHostCommand,rsync,Please install 'rsync', \
-       rsync --version </dev/null))
-
 $(eval $(call SetupHostCommand,which,Please install 'which', \
        /usr/bin/which which, \
        /bin/which which, \