ramips: use full 8MB flash on ZyXEL Keenetic
authorAlexey Dobrovolsky <dobrovolskiy.alexey@gmail.com>
Wed, 8 Apr 2020 18:43:36 +0000 (21:43 +0300)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 8 Apr 2020 20:03:40 +0000 (22:03 +0200)
ZyXEL Keenetic has 8MB flash, but OpenWrt uses only 4MB.
This commit fixes the problem.

WikiDevi page [1] says that ZyXEL Keenetic has FLA1: 8 MiB, there is
an article with specs [2] (in Russian).

[1] https://wikidevi.wi-cat.ru/ZyXEL_Keenetic
[2] https://3dnews.ru/608774/page-2.html

Fixes: FS#2487
Fixes: a7cbf59e0e04 ("ramips: add new device ZyXEL Keenetic as kn")
Signed-off-by: Alexey Dobrovolsky <dobrovolskiy.alexey@gmail.com>
target/linux/ramips/dts/rt3052_zyxel_keenetic.dts
target/linux/ramips/image/rt305x.mk

index ad641f47e48b708b6dc26868e926179825944304..436743cff3feae03c41043f4b02ba7fae78f4368 100644 (file)
@@ -48,7 +48,7 @@
                        partition@50000 {
                                compatible = "denx,uimage";
                                label = "firmware";
-                               reg = <0x50000 0x3b0000>;
+                               reg = <0x50000 0x7b0000>;
                        };
                };
        };
index 411f014800a1fa5ec4aa3444e75cde924139231f..819e9ac7cfbbe67816c614f5ae175176d90e73d4 100644 (file)
@@ -1150,7 +1150,7 @@ TARGET_DEVICES += zorlik_zl5900v2
 define Device/zyxel_keenetic
   SOC := rt3052
   BLOCKSIZE := 64k
-  IMAGE_SIZE := 3776k
+  IMAGE_SIZE := 7872k
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := Keenetic
   DEVICE_PACKAGES := kmod-usb2 kmod-usb-ehci kmod-usb-ledtrig-usbport