kernel: add kmod-input-leds
authorAnderson McKinley <coyoso@tuta.io>
Wed, 19 May 2021 23:38:21 +0000 (23:38 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 23 May 2021 13:10:30 +0000 (15:10 +0200)
Adds support for LEDs on input devices. Useful for example on x86 laptops-
allows re-purposing num/caps/scroll lock LEDs.

Signed-off-by: Anderson McKinley <coyoso@tuta.io>
package/kernel/linux/modules/leds.mk

index fdd5280fe409388be716972f738da222ec3add84..301d314b1d160ea4225ed69bbc3a35d81f964ac8 100644 (file)
@@ -159,3 +159,20 @@ define KernelPackage/leds-uleds/description
 endef
 
 $(eval $(call KernelPackage,leds-uleds))
+
+
+define KernelPackage/input-leds
+  SUBMENU:=$(LEDS_MENU)
+  TITLE:=Input device LED support
+  DEPENDS:=+kmod-input-core
+  KCONFIG:=CONFIG_INPUT_LEDS
+  FILES:=$(LINUX_DIR)/drivers/input/input-leds.ko
+  AUTOLOAD:=$(call AutoLoad,50,input-leds,1)
+endef
+
+define KernelPackage/input-leds/description
+ Provides support for LEDs on input devices- for example,
+ keyboard num/caps/scroll lock.
+endef
+
+$(eval $(call KernelPackage,input-leds))