kernel: package bcm53xx i2c module
authorChristian Lamparter <chunkeey@gmail.com>
Sun, 30 Aug 2020 01:04:42 +0000 (03:04 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Fri, 25 Sep 2020 17:32:34 +0000 (19:32 +0200)
The BCM5301x SoCs do have i2c. Since this is only
being used by the Meraki MR32, this will be packaged
as a module.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/bcm53xx/modules.mk

index b3bb42578c978df22e898855116db51eee564e1d..ab3bab3f1557006f2d7874635777f261657ef9d4 100644 (file)
@@ -35,3 +35,18 @@ define KernelPackage/phy-bcm-ns-usb3/description
 endef
 
 $(eval $(call KernelPackage,phy-bcm-ns-usb3))
+
+define KernelPackage/i2c-bcm-iproc
+  TITLE:=Broadcom iProc I2C controller
+  KCONFIG:=CONFIG_I2C_BCM_IPROC
+  DEPENDS:=@TARGET_bcm53xx +kmod-i2c-core
+  SUBMENU:=(I2C_MENU)
+  FILES:=$(LINUX_DIR)/drivers/i2c/busses/i2c-bcm-iproc.ko
+  AUTOLOAD:=$(call AutoLoad,59,i2c-bcm-iproc,1)
+endef
+
+define KernelPackage/i2c-bcm-iproc/description
+ Kernel module for the Broadcom iProc I2C controller.
+endef
+
+$(eval $(call KernelPackage,i2c-bcm-iproc))