ath79: rename tl-archer-c7 to archer-c7
authorChuanhong Guo <gch981213@gmail.com>
Thu, 2 Aug 2018 07:14:10 +0000 (15:14 +0800)
committerMathias Kresin <dev@kresin.me>
Mon, 6 Aug 2018 05:31:54 +0000 (07:31 +0200)
This router is called Archer C7 and the tl was used to identify
TP-LINK. Since we have added tplink in dts/board name, the tl
prefix is useless now.

Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9558_tplink_archer-c7-v2.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9558_tplink_archer-c7.dtsi [new file with mode: 0644]
target/linux/ath79/dts/qca9558_tplink_tl-archer-c7-v2.dts [deleted file]
target/linux/ath79/dts/qca9558_tplink_tl-archer-c7.dtsi [deleted file]
target/linux/ath79/image/generic-tp-link.mk

index d88a0f368ae557d757ca3afb3900b985e0e65e7f..f0233b4b282fdfa2e935d916c5420a1a8389c6d4 100755 (executable)
@@ -64,7 +64,7 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth0" "3:lan:1" "5:lan:2" "4:wan"
                ;;
-       tplink,tl-archer-c7-v2)
+       tplink,archer-c7-v2)
                ucidef_add_switch "switch0" \
                        "0@eth1" "2:lan" "3:lan" "4:lan" "5:lan" "6@eth0" "1:wan"
                ;;
index 0d58ea0dd4d57ecaf2bd907d44123e9e55da3308..038573f3e8a14a71ded79b5b67950b3e0a2a0c23 100644 (file)
@@ -91,13 +91,13 @@ case "$FIRMWARE" in
                ath10kcal_extract "ART" 20480 2116
                ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +16)
                ;;
-       tplink,re450-v2)
+       tplink,archer-c7-v2)
                ath10kcal_extract "art" 20480 2116
-               ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
+               ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth1/address) -1)
                ;;
-       tplink,tl-archer-c7-v2)
+       tplink,re450-v2)
                ath10kcal_extract "art" 20480 2116
-               ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth1/address) -1)
+               ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
                ;;
        ubnt,unifiac-lite|\
        ubnt,unifiac-mesh|\
diff --git a/target/linux/ath79/dts/qca9558_tplink_archer-c7-v2.dts b/target/linux/ath79/dts/qca9558_tplink_archer-c7-v2.dts
new file mode 100644 (file)
index 0000000..10e7a65
--- /dev/null
@@ -0,0 +1,46 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9558_tplink_archer-c7.dtsi"
+
+/ {
+       compatible = "tplink,archer-c7-v2", "qca,qca9558";
+       model = "TP-Link Archer C7 Version 2";
+};
+
+&gpio_keys {
+       rfkill {
+               gpios = <&gpio 23 GPIO_ACTIVE_LOW>;
+               linux,code = <KEY_RFKILL>;
+               linux,input-type = <EV_SW>;
+               debounce-interval = <60>;
+       };
+};
+
+&gpio_leds {
+       wlan5g {
+               label = "tp-link:green:wlan5g";
+               gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+               default-state = "off";
+               linux,default-trigger = "phy0tpt";
+       };
+};
+
+&mtdparts {
+       uboot: u-boot@0 {
+               reg = <0x000000 0x020000>;
+               read-only;
+       };
+
+       firmware@20000 {
+               reg = <0x020000 0xfd0000>;
+       };
+
+       art: art@ff0000 {
+               reg = <0xff0000 0x010000>;
+               read-only;
+       };
+};
\ No newline at end of file
diff --git a/target/linux/ath79/dts/qca9558_tplink_archer-c7.dtsi b/target/linux/ath79/dts/qca9558_tplink_archer-c7.dtsi
new file mode 100644 (file)
index 0000000..6fb25a9
--- /dev/null
@@ -0,0 +1,193 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9557.dtsi"
+
+/ {
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       aliases {
+               led-status = &system;
+       };
+
+       gpio_leds: leds {
+               compatible = "gpio-leds";
+
+               system: system {
+                       label = "tp-link:green:system";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               usb1 {
+                       label = "tp-link:green:usb1";
+                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       trigger-sources = <&hub_port1>;
+                       linux,default-trigger = "usbport";
+               };
+
+               usb2 {
+                       label = "tp-link:green:usb2";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       trigger-sources = <&hub_port0>;
+                       linux,default-trigger = "usbport";
+               };
+
+               led_wlan2g: wlan2g {
+                       label = "tp-link:green:wlan2g";
+                       gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       linux,default-trigger = "phy1tpt";
+               };
+
+               qss {
+                       label = "tp-link:green:qss";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+       };
+
+       gpio_keys: keys {
+               compatible = "gpio-keys";
+               #address-cells = <1>;
+               #size-cells = <0>;
+
+               reset {
+                       label = "Reset button";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       gpio-export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               gpio_usb1_power {
+                       gpio-export,name = "tp-link:power:usb1";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio 21 GPIO_ACTIVE_HIGH>;
+               };
+
+               gpio_usb2_power {
+                       gpio-export,name = "tp-link:power:usb2";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio 22 GPIO_ACTIVE_HIGH>;
+               };
+
+       };
+};
+
+&pcie1 {
+       status = "okay";
+};
+
+&uart {
+       status = "okay";
+};
+
+&gpio {
+       status = "okay";
+};
+
+&usb_phy0 {
+       status = "okay";
+};
+
+&usb0 {
+       status = "okay";
+
+       hub_port0: port@1 {
+               reg = <1>;
+               #trigger-source-cells = <0>;
+       };
+};
+
+&usb_phy1 {
+       status = "okay";
+};
+
+&usb1 {
+       status = "okay";
+
+       hub_port1: port@1 {
+               reg = <1>;
+               #trigger-source-cells = <0>;
+       };
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               mtdparts: partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+               };
+       };
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy0: ethernet-phy@0 {
+               reg = <0>;
+
+               qca,ar8327-initvals = <
+                       0x04 0x00080080 /* PORT0 PAD MODE CTRL */
+                       0x0c 0x07600000 /* PORT6 PAD MODE CTRL */
+                       0x50 0xc737c737 /* LED_CTRL0 */
+                       0x54 0x00000000 /* LED_CTRL1 */
+                       0x58 0x00000000 /* LED_CTRL2 */
+                       0x5c 0x0030c300 /* LED_CTRL3 */
+                       0x7c 0x0000007e /* PORT0_STATUS */
+                       0x94 0x0000007e /* PORT6 STATUS */
+                       >;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       mtd-mac-address = <&uboot 0x1fc00>;
+       mtd-mac-address-increment = <1>;
+       phy-handle = <&phy0>;
+
+       gmac-config {
+               device = <&gmac>;
+               rgmii-enabled = <1>;
+       };
+};
+
+&eth1 {
+       status = "okay";
+
+       mtd-mac-address = <&uboot 0x1fc00>;
+
+       fixed-link {
+               speed = <1000>;
+               full-duplex;
+       };
+};
+
+&wmac {
+       status = "okay";
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&uboot 0x1fc00>;
+};
diff --git a/target/linux/ath79/dts/qca9558_tplink_tl-archer-c7-v2.dts b/target/linux/ath79/dts/qca9558_tplink_tl-archer-c7-v2.dts
deleted file mode 100644 (file)
index e096db7..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "qca9558_tplink_tl-archer-c7.dtsi"
-
-/ {
-       compatible = "tplink,tl-archer-c7-v2", "qca,qca9558";
-       model = "TP-Link Archer C7 Version 2";
-};
-
-&gpio_keys {
-       rfkill {
-               gpios = <&gpio 23 GPIO_ACTIVE_LOW>;
-               linux,code = <KEY_RFKILL>;
-               linux,input-type = <EV_SW>;
-               debounce-interval = <60>;
-       };
-};
-
-&gpio_leds {
-       wlan5g {
-               label = "tp-link:green:wlan5g";
-               gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
-               default-state = "off";
-               linux,default-trigger = "phy0tpt";
-       };
-};
-
-&mtdparts {
-       uboot: u-boot@0 {
-               reg = <0x000000 0x020000>;
-               read-only;
-       };
-
-       firmware@20000 {
-               reg = <0x020000 0xfd0000>;
-       };
-
-       art: art@ff0000 {
-               reg = <0xff0000 0x010000>;
-               read-only;
-       };
-};
\ No newline at end of file
diff --git a/target/linux/ath79/dts/qca9558_tplink_tl-archer-c7.dtsi b/target/linux/ath79/dts/qca9558_tplink_tl-archer-c7.dtsi
deleted file mode 100644 (file)
index 6fb25a9..0000000
+++ /dev/null
@@ -1,193 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "qca9557.dtsi"
-
-/ {
-       chosen {
-               bootargs = "console=ttyS0,115200n8";
-       };
-
-       aliases {
-               led-status = &system;
-       };
-
-       gpio_leds: leds {
-               compatible = "gpio-leds";
-
-               system: system {
-                       label = "tp-link:green:system";
-                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
-                       default-state = "on";
-               };
-
-               usb1 {
-                       label = "tp-link:green:usb1";
-                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
-                       default-state = "off";
-                       trigger-sources = <&hub_port1>;
-                       linux,default-trigger = "usbport";
-               };
-
-               usb2 {
-                       label = "tp-link:green:usb2";
-                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
-                       default-state = "off";
-                       trigger-sources = <&hub_port0>;
-                       linux,default-trigger = "usbport";
-               };
-
-               led_wlan2g: wlan2g {
-                       label = "tp-link:green:wlan2g";
-                       gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
-                       default-state = "off";
-                       linux,default-trigger = "phy1tpt";
-               };
-
-               qss {
-                       label = "tp-link:green:qss";
-                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
-                       default-state = "off";
-               };
-       };
-
-       gpio_keys: keys {
-               compatible = "gpio-keys";
-               #address-cells = <1>;
-               #size-cells = <0>;
-
-               reset {
-                       label = "Reset button";
-                       linux,code = <KEY_RESTART>;
-                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
-                       debounce-interval = <60>;
-               };
-       };
-
-       gpio-export {
-               compatible = "gpio-export";
-               #size-cells = <0>;
-
-               gpio_usb1_power {
-                       gpio-export,name = "tp-link:power:usb1";
-                       gpio-export,output = <1>;
-                       gpios = <&gpio 21 GPIO_ACTIVE_HIGH>;
-               };
-
-               gpio_usb2_power {
-                       gpio-export,name = "tp-link:power:usb2";
-                       gpio-export,output = <1>;
-                       gpios = <&gpio 22 GPIO_ACTIVE_HIGH>;
-               };
-
-       };
-};
-
-&pcie1 {
-       status = "okay";
-};
-
-&uart {
-       status = "okay";
-};
-
-&gpio {
-       status = "okay";
-};
-
-&usb_phy0 {
-       status = "okay";
-};
-
-&usb0 {
-       status = "okay";
-
-       hub_port0: port@1 {
-               reg = <1>;
-               #trigger-source-cells = <0>;
-       };
-};
-
-&usb_phy1 {
-       status = "okay";
-};
-
-&usb1 {
-       status = "okay";
-
-       hub_port1: port@1 {
-               reg = <1>;
-               #trigger-source-cells = <0>;
-       };
-};
-
-&spi {
-       status = "okay";
-       num-cs = <1>;
-
-       flash@0 {
-               #address-cells = <1>;
-               #size-cells = <1>;
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <25000000>;
-
-               mtdparts: partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-               };
-       };
-};
-
-&mdio0 {
-       status = "okay";
-
-       phy0: ethernet-phy@0 {
-               reg = <0>;
-
-               qca,ar8327-initvals = <
-                       0x04 0x00080080 /* PORT0 PAD MODE CTRL */
-                       0x0c 0x07600000 /* PORT6 PAD MODE CTRL */
-                       0x50 0xc737c737 /* LED_CTRL0 */
-                       0x54 0x00000000 /* LED_CTRL1 */
-                       0x58 0x00000000 /* LED_CTRL2 */
-                       0x5c 0x0030c300 /* LED_CTRL3 */
-                       0x7c 0x0000007e /* PORT0_STATUS */
-                       0x94 0x0000007e /* PORT6 STATUS */
-                       >;
-       };
-};
-
-&eth0 {
-       status = "okay";
-
-       mtd-mac-address = <&uboot 0x1fc00>;
-       mtd-mac-address-increment = <1>;
-       phy-handle = <&phy0>;
-
-       gmac-config {
-               device = <&gmac>;
-               rgmii-enabled = <1>;
-       };
-};
-
-&eth1 {
-       status = "okay";
-
-       mtd-mac-address = <&uboot 0x1fc00>;
-
-       fixed-link {
-               speed = <1000>;
-               full-duplex;
-       };
-};
-
-&wmac {
-       status = "okay";
-       mtd-cal-data = <&art 0x1000>;
-       mtd-mac-address = <&uboot 0x1fc00>;
-};
index 49b28f7599f7cc33e44b4f6254790acc367fb2ff..6c9e7879cb4473073a8d6fd20e2c420dbc5023d1 100644 (file)
@@ -1,6 +1,6 @@
 include ./common-tp-link.mk
 
-define Device/tplink_tl-archer-c7-v2
+define Device/tplink_archer-c7-v2
   $(Device/tplink-16mlzma)
   ATH_SOC := qca9558
   DEVICE_TITLE := TP-LINK Archer C7 v2
@@ -10,7 +10,7 @@ define Device/tplink_tl-archer-c7-v2
   IMAGE/factory-us.bin := append-rootfs | mktplinkfw factory -C US
   IMAGE/factory-eu.bin := append-rootfs | mktplinkfw factory -C EU
 endef
-TARGET_DEVICES += tplink_tl-archer-c7-v2
+TARGET_DEVICES += tplink_archer-c7-v2
 
 define Device/tplink_tl-re450-v2
   $(Device/tplink)