ramips: add NAS goodies on U25AWF-H1 + U35[N|W]F
authorChristian Lamparter <chunkeey@gmail.com>
Tue, 20 Aug 2019 20:14:02 +0000 (22:14 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 24 Aug 2019 21:23:31 +0000 (23:23 +0200)
These devices are sold as a "NAS HDD Enclousure"
and have a "NAS Media Streaming & File Server & AP" on
the box. That's why I think they should have some support
for the HDD right out-of-the-box.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/ramips/image/mt7620.mk

index 455f83616850fefaa279324178a4c44f708ef4c1..e8f5db7d0a0a9c51e4b589c52d78b382e960e7cd 100644 (file)
@@ -497,7 +497,8 @@ define Device/kimax_u25awf-h1
   DEVICE_VENDOR := Kimax
   DEVICE_MODEL := U25AWF
   DEVICE_VARIANT := H1
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-storage kmod-scsi-core \
+                    kmod-fs-ext4 kmod-fs-vfat block-mount
   SUPPORTED_DEVICES += u25awf-h1
 endef
 TARGET_DEVICES += kimax_u25awf-h1
@@ -507,7 +508,8 @@ define Device/kimax_u35wf
   IMAGE_SIZE := 16064k
   DEVICE_VENDOR := Kimax
   DEVICE_MODEL := U35WF
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-storage kmod-scsi-core \
+                    kmod-fs-ext4 kmod-fs-vfat block-mount
 endef
 TARGET_DEVICES += kimax_u35wf