Extend checks on build prerequisites for building OpenWRT core
authorBas Mevissen <abuse@basmevissen.nl>
Mon, 19 Apr 2021 23:08:19 +0000 (01:08 +0200)
committerBaptiste Jonglez <git@bitsofnetworks.org>
Sat, 8 May 2021 10:45:55 +0000 (12:45 +0200)
OpenWRT requires a number of Perl modules to be installed. It wasn't checking on all of them.
This patch adds checks for Perl FindBin, File::Copy, File::Compare and Thread::Queue modules.

Failing to install these, will have the build break at some point. By adding these to the
prereq-build.mk script, they are checked on forehand.

Tested on a Fedora 33 and 34 (beta) that was freshly installed. Fedora appears to
break up Perl modules into small packages that need to be installed for the build to succeed.

Signed-off-by: Bas Mevissen <abuse@basmevissen.nl>
(cherry picked from commit f68c9474acf9a65b5a9538db8e45c173462487e3)

include/prereq-build.mk

index 86c22f7c959b326a8bed2f9331b38c3758c3151d..cb3dcc51e36ad6c04dbea72d96c3c2062eb1b7c1 100644 (file)
@@ -65,11 +65,22 @@ $(eval $(call TestHostCommand,perl-data-dumper, \
        Please install the Perl Data::Dumper module, \
        perl -MData::Dumper -e 1))
 
+$(eval $(call TestHostCommand,perl-findbin, \
+       Please install the Perl FindBin module, \
+       perl -MFindBin -e 1))
+
+$(eval $(call TestHostCommand,perl-file-copy, \
+       Please install the Perl File::Copy module, \
+       perl -MFile::Copy -e 1))
+
+$(eval $(call TestHostCommand,perl-file-compare, \
+       Please install the Perl File::Compare module, \
+       perl -MFile::Compare -e 1))
+
 $(eval $(call TestHostCommand,perl-thread-queue, \
        Please install the Perl Thread::Queue module, \
        perl -MThread::Queue -e 1))
 
-
 $(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
        gtar --version 2>&1 | grep GNU, \
        gnutar --version 2>&1 | grep GNU, \