rtl838x: d-link_dgs-1210: refactor common family bits
authorPetr Štetiar <ynezz@true.cz>
Wed, 4 Nov 2020 09:39:42 +0000 (10:39 +0100)
committerPetr Štetiar <ynezz@true.cz>
Mon, 9 Nov 2020 08:14:02 +0000 (09:14 +0100)
So the common bits can be easily shared with other boards in the family
and while at it add missing SPDX license identifiers into the DTS files
and fixed alphabetic sorting of the devices in the images.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/rtl838x/dts/rtl8382_d-link_dgs-1210-10p.dts
target/linux/rtl838x/dts/rtl8382_d-link_dgs-1210-16.dts
target/linux/rtl838x/dts/rtl8382_d-link_dgs-1210.dtsi [new file with mode: 0644]
target/linux/rtl838x/image/Makefile

index d7c6cbfc7c414daa2eba57256696a0fe579d8fb0..89e3746ad5af09e51d8b77db9a4c578484764dd3 100644 (file)
@@ -1,3 +1,5 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
 #include "rtl838x.dtsi"
 
 #include <dt-bindings/input/input.h>
index 3fb3cfb35346ae28600519f964e038d401fe7175..3843af1371a790656f43bb804370eb5e1b801b23 100644 (file)
@@ -1,87 +1,10 @@
-#include "rtl838x.dtsi"
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/gpio/gpio.h>
+#include "rtl8382_d-link_dgs-1210.dtsi"
 
 / {
        compatible = "d-link,dgs-1210-16", "realtek,rtl838x-soc";
        model = "D-Link DGS-1210-16";
-
-       aliases {
-               led-boot = &led_power;
-               led-failsafe = &led_power;
-               led-running = &led_power;
-               led-upgrade = &led_power;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,115200";
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               led_power: power {
-                       label = "green:power";
-                       gpios = <&gpio0 24 GPIO_ACTIVE_LOW>;
-               };
-       };
-};
-
-&gpio0 {
-       indirect-access-bus-id = <0>;
-};
-
-&spi0 {
-       status = "okay";
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <10000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x00000000 0x80000>;
-                               read-only;
-                       };
-                       partition@80000 {
-                               label = "u-boot-env";
-                               reg = <0x00080000 0x40000>;
-                               read-only;
-                       };
-                       partition@c0000 {
-                               label = "u-boot-env2";
-                               reg = <0x000c0000 0x40000>;
-                               read-only;
-                       };
-                       partition@280000 {
-                               label = "firmware";
-                               compatible = "denx,uimage";
-                               reg = <0x00100000 0xd80000>;
-                       };
-                       partition@be80000 {
-                               label = "kernel2";
-                               reg = <0x00e80000 0x180000>;
-                       };
-                       partition@1000000 {
-                               label = "sysinfo";
-                               reg = <0x01000000 0x40000>;
-                       };
-                       partition@1040000 {
-                               label = "rootfs2";
-                               reg = <0x01040000 0xc00000>;
-                       };
-                       partition@1c40000 {
-                               label = "jffs2";
-                               reg = <0x01c40000 0x3c0000>;
-                       };
-               };
-       };
 };
 
 &ethernet0 {
diff --git a/target/linux/rtl838x/dts/rtl8382_d-link_dgs-1210.dtsi b/target/linux/rtl838x/dts/rtl8382_d-link_dgs-1210.dtsi
new file mode 100644 (file)
index 0000000..74043c0
--- /dev/null
@@ -0,0 +1,84 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "rtl838x.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+
+/ {
+       aliases {
+               led-boot = &led_power;
+               led-failsafe = &led_power;
+               led-running = &led_power;
+               led-upgrade = &led_power;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power: power {
+                       label = "green:power";
+                       gpios = <&gpio0 24 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&gpio0 {
+       indirect-access-bus-id = <0>;
+};
+
+&spi0 {
+       status = "okay";
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x00000000 0x80000>;
+                               read-only;
+                       };
+                       partition@80000 {
+                               label = "u-boot-env";
+                               reg = <0x00080000 0x40000>;
+                               read-only;
+                       };
+                       partition@c0000 {
+                               label = "u-boot-env2";
+                               reg = <0x000c0000 0x40000>;
+                               read-only;
+                       };
+                       partition@280000 {
+                               label = "firmware";
+                               compatible = "denx,uimage";
+                               reg = <0x00100000 0xd80000>;
+                       };
+                       partition@be80000 {
+                               label = "kernel2";
+                               reg = <0x00e80000 0x180000>;
+                       };
+                       partition@1000000 {
+                               label = "sysinfo";
+                               reg = <0x01000000 0x40000>;
+                       };
+                       partition@1040000 {
+                               label = "rootfs2";
+                               reg = <0x01040000 0xc00000>;
+                       };
+                       partition@1c40000 {
+                               label = "jffs2";
+                               reg = <0x01c40000 0x3c0000>;
+                       };
+               };
+       };
+};
index f490fa7ffe92fa446962cbdbb7db3c63215fbd73..cd384c53452240b3c03e17863881c19998f50630 100644 (file)
@@ -41,22 +41,24 @@ define Device/allnet_all-sg8208m
 endef
 TARGET_DEVICES += allnet_all-sg8208m
 
-define Device/d-link_dgs-1210-16
+define Device/d-link_dgs-1210
   SOC := rtl8382
   IMAGE_SIZE := 13824k
   DEVICE_VENDOR := D-Link
-  DEVICE_MODEL := DGS-1210-16
   DEVICE_PACKAGES := ip-full ip-bridge ethtool tc
 endef
-TARGET_DEVICES += d-link_dgs-1210-16
 
 define Device/d-link_dgs-1210-10p
-  SOC := rtl8382
-  IMAGE_SIZE := 13824k
-  DEVICE_VENDOR := D-Link
+  $(Device/d-link_dgs-1210)
   DEVICE_MODEL := DGS-1210-10P
-  DEVICE_PACKAGES := ip-full ip-bridge ethtool tc lua-rs232
+  DEVICE_PACKAGES += lua-rs232
 endef
 TARGET_DEVICES += d-link_dgs-1210-10p
 
+define Device/d-link_dgs-1210-16
+  $(Device/d-link_dgs-1210)
+  DEVICE_MODEL := DGS-1210-16
+endef
+TARGET_DEVICES += d-link_dgs-1210-16
+
 $(eval $(call BuildImage))