kernel: fix kmod-tpm 4.19 dependencies
authorChristian Lamparter <chunkeey@gmail.com>
Thu, 20 Jun 2019 19:46:55 +0000 (21:46 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 22 Jun 2019 11:17:47 +0000 (13:17 +0200)
This patch fixes the ath79-nand build error:
|Package kmod-tpm is missing dependencies for the following libraries:
|rng-core.ko

by making it depend on rng-core from 4.19 onwards.
This should work as 4.9 is gone so only 4.14 and 4.19
are there.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/kernel/linux/modules/other.mk

index 16b438461e58d4be1f190e3b49e363e690110515..e98b8a9223fbd3635f0bb07c1d8b35752db40efb 100644 (file)
@@ -1085,6 +1085,7 @@ $(eval $(call KernelPackage,bmp085-spi))
 define KernelPackage/tpm
   SUBMENU:=$(OTHER_MENU)
   TITLE:=TPM Hardware Support
+  DEPENDS:= +!LINUX_4_14:kmod-random-core
   KCONFIG:= CONFIG_TCG_TPM
   FILES:= $(LINUX_DIR)/drivers/char/tpm/tpm.ko
   AUTOLOAD:=$(call AutoLoad,10,tpm,1)