sdk: fix missing include directories
authorPetr Štetiar <ynezz@true.cz>
Sun, 1 Nov 2020 16:31:40 +0000 (17:31 +0100)
committerPetr Štetiar <ynezz@true.cz>
Mon, 2 Nov 2020 07:39:49 +0000 (08:39 +0100)
It's not possible to compile some applications which are using
`-Werror=missing-include-dirs` compiler flags with the SDK as some
target directories are missing in the SDK tarball:

 cc1: error: staging_dir/target/usr/include: No such file or directory [-Werror=missing-include-dirs]
 cc1: error: staging_dir/target/include: No such file or directory [-Werror=missing-include-dirs]

Fix this by adding the missing directories in the SDK.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/sdk/Makefile

index 4a9dc8be41b85c1e55f8f4e1cfc7e8fd68783fdd..caec7178e9cf89e7bded5d15a33ffb799fbbb25e 100644 (file)
@@ -82,7 +82,12 @@ KERNEL_FILES := $(patsubst $(TOPDIR)/%,%,$(wildcard $(addprefix $(LINUX_DIR)/,$(
 all: compile
 
 $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
-       mkdir -p $(SDK_BUILD_DIR)/dl $(SDK_BUILD_DIR)/package
+       mkdir -p \
+               $(SDK_BUILD_DIR)/dl \
+               $(SDK_BUILD_DIR)/package \
+               $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TARGET)/include \
+               $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TARGET)/usr/include
+
        $(CP) -L $(INCLUDE_DIR) $(SCRIPT_DIR) $(SDK_BUILD_DIR)/
        $(TAR) -cf - -C $(TOPDIR) \
                `cd $(TOPDIR); find $(KDIR_BASE)/ -name \*.ko` \