rtl838x: fine tune default package set
authorPetr Štetiar <ynezz@true.cz>
Mon, 9 Nov 2020 17:15:53 +0000 (18:15 +0100)
committerPetr Štetiar <ynezz@true.cz>
Mon, 9 Nov 2020 20:50:06 +0000 (21:50 +0100)
Althought most of the switches aren't routers, they can be used as such,
so let's add some of the packages from the router's DEVICE_TYPE. While
at it, remove swconfig package which is not needed on DSA targets.

Acked-by: John Crispin <john@phrozen.org>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/rtl838x/Makefile

index 83cb074b89b688e1b4989bace4bf2fd94b44ba35..a4e203718d9090694179c604d86a1bf9dec4a2ee 100644 (file)
@@ -21,6 +21,7 @@ include $(INCLUDE_DIR)/target.mk
 
 FEATURES := $(filter-out mips16,$(FEATURES))
 
-DEFAULT_PACKAGES += swconfig uboot-envtools ethtool kmod-gpio-button-hotplug
+DEFAULT_PACKAGES += uboot-envtools ethtool kmod-gpio-button-hotplug \
+       dnsmasq firewall ip6tables iptables odhcp6c odhcpd-ipv6only
 
 $(eval $(call BuildTarget))