malta: restore "be" subtarget from being source-only
[openwrt/staging/yousong.git] / include / kernel-build.mk
index 062c458ab7715bbacf904e4a9a777454c2812386..7d1e23c6eaa10972de071f28cbbb40047c49de15 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/depends.mk
 
@@ -43,7 +42,7 @@ endef
 define Download/kernel
   URL:=$(LINUX_SITE)
   FILE:=$(LINUX_SOURCE)
-  MD5SUM:=$(LINUX_KERNEL_MD5SUM)
+  HASH:=$(LINUX_KERNEL_HASH)
 endef
 
 KERNEL_GIT_OPTS:=
@@ -60,7 +59,7 @@ define Download/git-kernel
   PROTO:=git
   VERSION:=$(CONFIG_KERNEL_GIT_BRANCH)
   FILE:=$(LINUX_SOURCE)
-  SUBDIR:=linux-$(KERNEL_PATCHVER)
+  SUBDIR:=linux-$(LINUX_VERSION)
   OPTS:=$(KERNEL_GIT_OPTS)
 endef
 
@@ -152,7 +151,7 @@ define BuildKernel
   endef
 
   download: $(if $(LINUX_SITE),$(DL_DIR)/$(LINUX_SOURCE))
-  prepare: $(STAMP_CONFIGURED)
+  prepare: $(STAMP_PREPARED)
   compile: $(LINUX_DIR)/.modules
        $(MAKE) -C image compile TARGET_BUILD=