lantiq: Tune the XWAY subtarget cflags
[openwrt/staging/yousong.git] / package / kernel / modules / fs.mk
index 9226ad90312d3377adbce0c88c46b498a9050cae..ecdfb6d3a72b80ef2b08edd51852e955fbbe1eb8 100644 (file)
@@ -10,7 +10,7 @@ FS_MENU:=Filesystems
 define KernelPackage/fs-autofs4
   SUBMENU:=$(FS_MENU)
   TITLE:=AUTOFS4 filesystem support
-  KCONFIG:=CONFIG_AUTOFS4_FS 
+  KCONFIG:=CONFIG_AUTOFS4_FS
   FILES:=$(LINUX_DIR)/fs/autofs4/autofs4.ko
   AUTOLOAD:=$(call AutoLoad,30,autofs4)
 endef
@@ -58,7 +58,8 @@ define KernelPackage/fs-cifs
     +kmod-crypto-md5 \
     +kmod-crypto-md4 \
     +kmod-crypto-des \
-    +kmod-crypto-ecb
+    +kmod-crypto-ecb \
+    +!LINUX_3_3&&!LINUX_3_6:kmod-crypto-sha256
 endef
 
 define KernelPackage/fs-cifs/description
@@ -68,6 +69,22 @@ endef
 $(eval $(call KernelPackage,fs-cifs))
 
 
+define KernelPackage/fs-configfs
+  SUBMENU:=$(FS_MENU)
+  TITLE:=Configuration filesystem support
+  KCONFIG:= \
+       CONFIG_CONFIGFS_FS
+  FILES:=$(LINUX_DIR)/fs/configfs/configfs.ko
+  AUTOLOAD:=$(call AutoLoad,30,configfs)
+endef
+
+define KernelPackage/fs-configfs/description
+ Kernel module for configfs support
+endef
+
+$(eval $(call KernelPackage,fs-configfs))
+
+
 define KernelPackage/fs-exportfs
   SUBMENU:=$(FS_MENU)
   TITLE:=exportfs kernel server support
@@ -94,7 +111,7 @@ define KernelPackage/fs-ext4
        $(LINUX_DIR)/fs/jbd2/jbd2.ko \
        $(LINUX_DIR)/fs/mbcache.ko
   AUTOLOAD:=$(call AutoLoad,30,mbcache jbd2 ext4,1)
-  $(call AddDepends/crc16)
+  $(call AddDepends/crc16, +!LINUX_3_3:kmod-crypto-hash)
 endef
 
 define KernelPackage/fs-ext4/description
@@ -104,9 +121,24 @@ endef
 $(eval $(call KernelPackage,fs-ext4))
 
 
+define KernelPackage/fuse
+  SUBMENU:=$(FS_MENU)
+  TITLE:=FUSE (Filesystem in Userspace) support
+  KCONFIG:= CONFIG_FUSE_FS
+  FILES:=$(LINUX_DIR)/fs/fuse/fuse.ko
+  AUTOLOAD:=$(call AutoLoad,80,fuse)
+endef
+
+define KernelPackage/fuse/description
+ Kernel module for userspace filesystem support
+endef
+
+$(eval $(call KernelPackage,fuse))
+
+
 define KernelPackage/fs-hfs
   SUBMENU:=$(FS_MENU)
-  TITLE:=HFS+ filesystem support
+  TITLE:=HFS filesystem support
   KCONFIG:=CONFIG_HFS_FS
   FILES:=$(LINUX_DIR)/fs/hfs/hfs.ko
   AUTOLOAD:=$(call AutoLoad,30,hfs)
@@ -139,6 +171,7 @@ $(eval $(call KernelPackage,fs-hfsplus))
 define KernelPackage/fs-isofs
   SUBMENU:=$(FS_MENU)
   TITLE:=ISO9660 filesystem support
+  DEPENDS:=+kmod-lib-zlib
   KCONFIG:=CONFIG_ISO9660_FS CONFIG_JOLIET=y CONFIG_ZISOFS=n
   FILES:=$(LINUX_DIR)/fs/isofs/isofs.ko
   AUTOLOAD:=$(call AutoLoad,30,isofs)